Update babel to 0.15 add a sample configuration file
authorFlorian Fainelli <florian@openwrt.org>
Sun, 27 Jul 2008 17:05:37 +0000 (17:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 27 Jul 2008 17:05:37 +0000 (17:05 +0000)
SVN-Revision: 11964

ipv6/babel/Makefile
ipv6/babel/files/babel.conf [new file with mode: 0644]

index ca09a1ff07815633b7dcca05704b82203171b43c..19f22b3e08fb4ca65f60902f7cfff8123c0f819a 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babel
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babel
-PKG_VERSION:=0.14
+PKG_VERSION:=0.15
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=d850a0e5044acb64038205197503937e
+PKG_MD5SUM:=510da09a471bba78bb8178810094e3de
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,6 +36,10 @@ define Package/babel/description
  never counting to infinity.
 endef
 
  never counting to infinity.
 endef
 
+define Package/babel/conffiles
+/etc/babel.conf
+endef
+
 MAKE_FLAGS += \
        CC="$(TARGET_CC)" \
        CFLAGS="$(TARGET_CFLAGS)" \
 MAKE_FLAGS += \
        CC="$(TARGET_CC)" \
        CFLAGS="$(TARGET_CFLAGS)" \
@@ -43,6 +47,8 @@ MAKE_FLAGS += \
 define Package/babel/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/babel $(1)/usr/sbin/
 define Package/babel/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/babel $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/babel.conf $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,babel))
 endef
 
 $(eval $(call BuildPackage,babel))
diff --git a/ipv6/babel/files/babel.conf b/ipv6/babel/files/babel.conf
new file mode 100644 (file)
index 0000000..20ba36c
--- /dev/null
@@ -0,0 +1,56 @@
+# babel config file
+# Copyright (C) 2008 Juliusz Chroboczek, L. Aaron Kaplan
+#   <jch@pps.jussieu.fr> , <aaron@lo-res.org>
+#
+# This config file simply docuements sample entries. 
+# "redistribute" means: redistribute routes from other 
+#  routing protocols into babel. "local" means addresses assigned to local interfaces.
+#
+# the default rules are:
+#
+## redistribute local 
+## redistribute deny
+#
+# this says, redistribute local addresses but no other routes
+
+
+
+# redistribute IPv4 default route into babel 
+## redistribute local 0.0.0.0/0 le 0 metric 128
+
+# same but for IPv6
+## redistribute local ::/0 le 0 metric 128
+
+# don't redistribute all local addresses, only selected ones
+# after the first line, the "deny" rules kicks in. After the "deny"
+# no redistribute local rules are going to match
+## redistribute local ip 192.160.4.0/24 
+## redistribute local deny
+# babel config file
+# Copyright (C) 2008 Juliusz Chroboczek, L. Aaron Kaplan
+#   <jch@pps.jussieu.fr> , <aaron@lo-res.org>
+#
+# This config file simply docuements sample entries. 
+# "redistribute" means: redistribute routes from other 
+#  routing protocols into babel. "local" means addresses assigned to local interfaces.
+#
+# the default rules are:
+#
+## redistribute local 
+## redistribute deny
+#
+# this says, redistribute local addresses but no other routes
+
+
+
+# redistribute IPv4 default route into babel 
+## redistribute local 0.0.0.0/0 le 0 metric 128
+
+# same but for IPv6
+## redistribute local ::/0 le 0 metric 128
+
+# don't redistribute all local addresses, only selected ones
+# after the first line, the "deny" rules kicks in. After the "deny"
+# no redistribute local rules are going to match
+## redistribute local ip 192.160.4.0/24 
+## redistribute local deny