usb-modeswitch: Fix a condition to compare default product id and switched product...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Nov 2011 02:59:10 +0000 (02:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Nov 2011 02:59:10 +0000 (02:59 +0000)
These default product id and switched product id are hex string variables, so this comparison operator should be '='.

Signed-off-by: Kentaro Matsuyama <kentaro.matsuyama@gmail.com>
SVN-Revision: 28872

utils/usb-modeswitch/Makefile
utils/usb-modeswitch/files/modeswitch.hotplug

index 62444f1d475aa026dca3b02b5dac7f52c82bc25c..c033c7291404ecf1c7ef5e048d3155b2179de4dd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usb-modeswitch
 PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.draisberghof.de/usb_modeswitch
index 7f9ce9411d1e45363aebb18b2d6e335d5927f22d..8042451373b57bd13a714923fd17243127460ecd 100644 (file)
@@ -127,7 +127,7 @@ if [ "$ACTION" = add ]; then
                        [ -f "$usb_dir/idVendor" ] || usb_dir="${usb_dir%/*}"
                        while [ $switching_done -lt 1 -a $switching_tries -le 6 ]; do
                                $modeswitch -I -D -n -s 30 -c "${configs%% *}"
-                               if [ $(sanitize "$usb_dir/idProduct") -eq $uPid ]; then
+                               if [ $(sanitize "$usb_dir/idProduct") = $uPid ]; then
                                        log "switching seemingly failed"
                                else
                                        switching_done=1