[Packages] net/openssh:
authorOliver Ertl <oliver@ertl-net.net>
Tue, 12 Feb 2008 12:28:19 +0000 (12:28 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Tue, 12 Feb 2008 12:28:19 +0000 (12:28 +0000)
 * Package ssh-keysign as well. Required for host-based authentication (http://lists.openwrt.org/pipermail/openwrt-devel/2008-February/001705.html)

Signed-off-by: Michael Vogt <michu at neophob.com>
SVN-Revision: 10446

net/openssh/Makefile

index ec55e6b8944cf4b9bc549326a54e6dab6672eab5..606638a88202ffb63be02d3c9139b52cd6870ecf 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -166,9 +166,7 @@ endef
 
 define Package/openssh-client-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-add $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-agent $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-keyscan $(1)/usr/bin/
+       $(INSTALL_BIN) $(foreach bin,add agent keyscan keysign,$(PKG_BUILD_DIR)/ssh-$(bin)) $(1)/usr/bin/
 endef
 
 define Package/openssh-server/install