ar71xx: add profile and build image for UniFi AP Pro
authorGabor Juhos <juhosg@openwrt.org>
Mon, 17 Dec 2012 12:28:21 +0000 (12:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 17 Dec 2012 12:28:21 +0000 (12:28 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34730

target/linux/ar71xx/generic/profiles/ubnt.mk
target/linux/ar71xx/image/Makefile

index dc26956b39da542e9bd32e99f05d9b6afdb98bfc..d8e24d0032d75231d27be8207fe55294fd108282 100644 (file)
@@ -49,6 +49,18 @@ endef
 
 $(eval $(call Profile,UBNTUNIFIOUTDOOR))
 
+define Profile/UAPPRO
+       NAME:=Ubiquiti UniFi AP Pro
+       PACKAGES:=
+endef
+
+define Profile/UAPPRO/Description
+       Package set optimized for the Ubiquiti UniFi AP Pro.
+endef
+
+$(eval $(call Profile,UAPPRO))
+
+
 define Profile/UBNT
        NAME:=Ubiquiti Products
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
index 53b4f90a0a53a37f59d6fa62f860cae209cbdee3..83037c4835430125568bde90b51753059f239663 100644 (file)
@@ -179,6 +179,7 @@ dlrtdev_mtdlayout_fat=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,1024k(kernel),
 pb92_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2752k(rootfs),896k(kernel),64k(nvram),64k(art)ro,3648k@0x50000(firmware)
 planex_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,960k(kernel),6784k(rootfs),128k(art)ro,7744k@0x50000(firmware)
 ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware)
+uap_pro_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1536k(kernel),14208k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
 ubdev_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6464k(rootfs),64k(certs),256k(cfg)ro,64k(EEPROM)ro,7488k@0x50000(firmware)
 whrhpg300n_mtdlayout=mtdparts=spi0.0:248k(u-boot)ro,8k(u-boot-env)ro,960k(kernel),2816k(rootfs),64k(art)ro,3712k@0x40000(firmware)
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
@@ -399,6 +400,30 @@ define Image/Build/MyLoader
                $(call imgname,$(1),$(2))-$(5)-factory.img
 endef
 
+define Image/Build/UAPPRO
+       $(call MkuImageLzma,$(2),$(3) $(uap_pro_mtdlayout))
+       -rm -rf $(KDIR_TMP)/$(2)
+       mkdir -p $(KDIR_TMP)/$(2)/image
+       cp $(KDIR_TMP)/vmlinux-$(2).uImage $(KDIR_TMP)/$(2)/image/kernel0
+       $(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
+               --pad --big-endian --squash-uids -v -e 64KiB \
+               -o $(KDIR_TMP)/$(2)-kernel.jffs2 \
+               -d $(KDIR_TMP)/$(2)/image \
+               2>&1 1>/dev/null | awk '/^.+$$$$/'
+       -rm -rf $(KDIR_TMP)/$(2)
+       $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR_TMP)/$(2)-kernel.jffs2 64
+       $(call CatFiles,$(KDIR_TMP)/$(2)-kernel.jffs2,1572864,$(KDIR)/root.$(1),14548992,$(call sysupname,$(1),$(2)))
+       -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
+               -v $(5).$(6).v6.0.0-OpenWrt-$(REVISION) \
+               -p jffs2:0x50000:0xf60000:0:0:$(call sysupname,$(1),$(2)) \
+               -o $(call factoryname,$(1),$(2))
+       -rm -f $(KDIR_TMP)/$(2)-kernel.jffs2
+endef
+
+define Image/Build/UAPPRO/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(uap_pro_mtdlayout))
+endef
+
 define Image/Build/UBNTXM
        $(call MkuImageLzma,$(2),$(3) $(ubntxm_mtdlayout))
        $(call Sysupgrade/KRuImage,$(1),$(2),1048576,6684672)
@@ -410,7 +435,6 @@ define Image/Build/UBNTXM
                -o $(call factoryname,$(1),$(2))
 endef
 
-
 define Image/Build/UBDEV
        $(call MkuImageLzma,$(2),$(3) $(ubdev_mtdlayout))
        $(call Sysupgrade/KRuImage,$(1),$(2),1048576,6684672)
@@ -889,6 +913,8 @@ $(eval $(call SingleProfile,TPLINK-LZMA,$(fs_64kraw),TLWDR3600V1,tl-wdr3600-v1,T
 $(eval $(call SingleProfile,TPLINK-LZMA,$(fs_64kraw),TLWDR4300V1,tl-wdr4300-v1,TL-WDR4300,ttyS0,115200,0x43000001,1,8Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,$(fs_64kraw),TLWDR4310V1,tl-wdr4310-v1,TL-WDR4300,ttyS0,115200,0x43100001,1,8Mlzma))
 
+$(eval $(call SingleProfile,UAPPRO,$(fs_64k),UAPPRO,ubnt-uap-pro,UAP-PRO,ttyS0,115200,BZ,BZ,ar934x))
+
 $(eval $(call SingleProfile,UBDEV,$(fs_64k),UBDEV01,ubdev01,UBNT-UF,ttyS0,115200,XM,XM,ar7240))
 
 $(eval $(call SingleProfile,UBNT,$(fs_64k),UBNTRS,ubnt-rs,UBNT-RS,ttyS0,115200,RS,RSx,ar7100))
@@ -931,7 +957,7 @@ $(eval $(call MultiProfile,TLWR741,TLWR741NV1 TLWR741NV2 TLWR741NV4))
 $(eval $(call MultiProfile,TLWR841,TLWR841NV15 TLWR841NV3 TLWR841NV5 TLWR841NV7 TLWR841NV8))
 $(eval $(call MultiProfile,TLWR941,TLWR941NV2 TLWR941NV3 TLWR941NV4))
 $(eval $(call MultiProfile,TLWDR4300,TLWDR3600V1 TLWDR4300V1 TLWDR4310V1))
-$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTNANOM UBNTUNIFI UBNTUNIFIOUTDOOR))
+$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTNANOM UBNTUNIFI UBNTUNIFIOUTDOOR UAPPRO))
 $(eval $(call MultiProfile,WNDR3700,WNDR3700V1 WNDR3700V2 WNDR3800 WNDRMAC WNDRMACV2))
 $(eval $(call MultiProfile,WP543,WP543_2M WP543_4M WP543_8M WP543_16M))
 $(eval $(call MultiProfile,WPE72,WPE72_4M WPE72_8M WPE72_16M))