projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
|
inline
| side by side (parent:
7209608
)
[packages] freeswitch: move initscript from InstallDev to freeswitch package
author
Nicolas Thill
<nico@openwrt.org>
Wed, 21 Oct 2009 14:58:32 +0000
(14:58 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Wed, 21 Oct 2009 14:58:32 +0000
(14:58 +0000)
SVN-Revision: 18116
net/freeswitch/Makefile
patch
|
blob
|
history
diff --git
a/net/freeswitch/Makefile
b/net/freeswitch/Makefile
index 2f784b301b578b9383cb6a9031f0ce549719f4e4..b8c84f6853271fc1fd428a30aa7369373312ddbc 100644
(file)
--- a/
net/freeswitch/Makefile
+++ b/
net/freeswitch/Makefile
@@
-246,10
+246,6
@@
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/include/* $(1)/usr/include/freeswitch/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/include/* $(1)/usr/include/freeswitch/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.{a,so*} $(1)/usr/lib/
- $(INSTALL_DIR) $(1)/etc/default
- $(INSTALL_DATA) ./files/freeswitch.default $(1)/etc/default/freeswitch
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/freeswitch.init $(1)/etc/init.d/freeswitch
endef
define Package/freeswitch/install
endef
define Package/freeswitch/install
@@
-258,6
+254,10
@@
define Package/freeswitch/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/freeswitch
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/freeswitch
+ $(INSTALL_DIR) $(1)/etc/default
+ $(INSTALL_DATA) ./files/freeswitch.default $(1)/etc/default/freeswitch
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/freeswitch.init $(1)/etc/init.d/freeswitch
endef
define Package/freeswitch-default/install
endef
define Package/freeswitch-default/install