[package] uboot-envtools: add kirkwood board support
authorLuka Perkov <luka@openwrt.org>
Mon, 16 Jul 2012 22:32:00 +0000 (22:32 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 16 Jul 2012 22:32:00 +0000 (22:32 +0000)
SVN-Revision: 32756

package/uboot-envtools/Makefile
package/uboot-envtools/files/kirkwood [new file with mode: 0644]

index 45f7430b88c87c9a9de8256929149e8e6d2251a8..8169840d9a88677c9baa0840f7a224e6bf141075 100644 (file)
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_TARGET_ar71xx),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/ar71xx $(1)/etc/uci-defaults/uboot-envtools
 endif
+ifneq ($(CONFIG_TARGET_kirkwood),)
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_BIN) ./files/kirkwood $(1)/etc/uci-defaults/uboot-envtools
+endif
 ifneq ($(CONFIG_TARGET_lantiq),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/lantiq $(1)/etc/uci-defaults/uboot-envtools
diff --git a/package/uboot-envtools/files/kirkwood b/package/uboot-envtools/files/kirkwood
new file mode 100644 (file)
index 0000000..cad53aa
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/kirkwood.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+hardware=$(kirkwood_hardware_name)
+
+case "$hardware" in
+"RaidSonic ICY BOX IB-NAS6210")
+       ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
+       ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0