[backfire] busybox: backport r29156
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Nov 2011 17:55:01 +0000 (17:55 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Nov 2011 17:55:01 +0000 (17:55 +0000)
SVN-Revision: 29159

package/busybox/Makefile
package/busybox/patches/700-hexdump_segfault_fix.patch [new file with mode: 0644]

index 3289bd679e822d8f13279c8332f449298b18554d..0706480b6be151a89403be2ddac5f0e5c25b5b07 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.15.3
-PKG_RELEASE:=3.2
+PKG_RELEASE:=3.3
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/busybox/patches/700-hexdump_segfault_fix.patch b/package/busybox/patches/700-hexdump_segfault_fix.patch
new file mode 100644 (file)
index 0000000..9bb9ad8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/libbb/dump.c
++++ b/libbb/dump.c
+@@ -304,7 +304,7 @@ static void rewrite(priv_dumper_t *dumpe
+               ) {
+                       fu->reps += (dumper->blocksize - fs->bcnt) / fu->bcnt;
+               }
+-              if (fu->reps > 1) {
++              if (fu->reps > 1 && fu->nextpr) {
+                       for (pr = fu->nextpr;; pr = pr->nextpr)
+                               if (!pr->nextpr)
+                                       break;