disable more modules not supported on UML
authorNicolas Thill <nico@openwrt.org>
Thu, 20 Sep 2007 07:46:00 +0000 (07:46 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 20 Sep 2007 07:46:00 +0000 (07:46 +0000)
SVN-Revision: 8857

package/kernel/modules/video.mk
package/rt2x00/Makefile

index 4a360316486764e43f68f1aafc5578808dfcbb83..838c4c5f62b89a09b98f7caebbc67d9525228390 100644 (file)
@@ -11,6 +11,7 @@ VIDEO_MENU:=Video Support
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
+  DEPENDS:= @!TARGET_uml
   KCONFIG:= \
        CONFIG_VIDEO_DEV \
        CONFIG_VIDEO_V4L1=y \
index 71cd418be8f5a1c0a0e3d93ed98823e83e1ed4d8..9dd9286933a9f6163471fae354b747a3df54dfce 100644 (file)
@@ -29,7 +29,7 @@ endif
 define KernelPackage/rt2x00/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Ralink Drivers for RT2x00 cards
-  DEPENDS:=@LINUX_2_6 @!TARGET_atheros
+  DEPENDS:=@LINUX_2_6 @!TARGET_atheros @!TARGET_uml
   KCONFIG:=CONFIG_MAC80211
 endef