[package] php5: Fix build when simplexml is selected (#7758)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 21:22:32 +0000 (21:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 21:22:32 +0000 (21:22 +0000)
The build fails since the php module is statically disabled. This patch
adds the required magic.

This should also finally close #7758.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 26341

lang/php5/Makefile

index 8022f63154d39f3e924ad4cbb165573bf476707b..d56890141314abc74e78c7b6e76e37ae9796e6be 100644 (file)
@@ -114,7 +114,6 @@ PKG_CONFIGURE_OPTS:= \
        --disable-short-tags \
        \
        --without-gettext \
-       --disable-simplexml \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
        --with-pcre-regex="$(STAGING_DIR)/usr" \
@@ -283,6 +282,12 @@ else
   PKG_CONFIGURE_OPTS+= --disable-session
 endif
 
+ifneq ($(CONFIG_PACKAGE_php5-mod-simplexml),)
+  PKG_CONFIGURE_OPTS+= --enable-simplexml=shared
+else
+  PKG_CONFIGURE_OPTS+= --disable-simplexml
+endif
+
 ifneq ($(CONFIG_PACKAGE_php5-mod-soap),)
   PKG_CONFIGURE_OPTS+= --enable-soap=shared
 else