[8.09] merge r17571 and r17572
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Sep 2009 02:34:40 +0000 (02:34 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Sep 2009 02:34:40 +0000 (02:34 +0000)
SVN-Revision: 17654

package/base-files/Makefile
package/base-files/files/etc/init.d/done
package/base-files/files/etc/rc.local [new file with mode: 0644]
package/base-files/files/sbin/sysupgrade

index f46fe7450905d7a252a13b339ce86304b45e9b41..aea4ea7242eaecbc09c5f0c3dfd92d12a92d127c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=14.7
+PKG_RELEASE:=14.8
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 0640b61938413fb563a9933f02f5a46ba0f39c09..82786691203b25ae91818d745e061d0cdf0198d0 100755 (executable)
@@ -9,6 +9,11 @@ boot() {
                lock -u /tmp/.switch2jffs
        }
 
+       # process user commands
+       [ -f /etc/rc.local ] && {
+               sh /etc/rc.local
+       }
+
        # set leds to normal state
        . /etc/diag.sh
        set_state done
diff --git a/package/base-files/files/etc/rc.local b/package/base-files/files/etc/rc.local
new file mode 100644 (file)
index 0000000..5639477
--- /dev/null
@@ -0,0 +1,4 @@
+# Put your custom commands here that should be executed once
+# the system init finished. By default this file does nothing.
+
+exit 0
index ecc5e9a70888163b96ee4cd326fbd60bd23eba11..0936d9ec32d66410a2a6fac9cd367592b5d18285 100755 (executable)
@@ -54,7 +54,7 @@ EOF
 
 add_uci_conffiles() {
        local file="$1"
-       find /etc/config /etc/passwd /etc/group /etc/dropbear /etc/firewall.user > "$file"
+       find /etc/config /etc/passwd /etc/group /etc/dropbear /etc/firewall.user /etc/rc.local > "$file"
        return 0
 }