atheros: add early-printk support
authorGabor Juhos <juhosg@openwrt.org>
Sun, 14 Mar 2010 16:08:21 +0000 (16:08 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 14 Mar 2010 16:08:21 +0000 (16:08 +0000)
SVN-Revision: 20201

12 files changed:
target/linux/atheros/patches-2.6.30/101-early-printk-support.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.30/105-ar2315_pci.patch
target/linux/atheros/patches-2.6.30/210-reset_button.patch
target/linux/atheros/patches-2.6.31/101-early-printk-support.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.31/105-ar2315_pci.patch
target/linux/atheros/patches-2.6.31/210-reset_button.patch
target/linux/atheros/patches-2.6.32/101-early-printk-support.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.32/105-ar2315_pci.patch
target/linux/atheros/patches-2.6.32/210-reset_button.patch
target/linux/atheros/patches-2.6.33/101-early-printk-support.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.33/105-ar2315_pci.patch
target/linux/atheros/patches-2.6.33/210-reset_button.patch

diff --git a/target/linux/atheros/patches-2.6.30/101-early-printk-support.patch b/target/linux/atheros/patches-2.6.30/101-early-printk-support.patch
new file mode 100644 (file)
index 0000000..c09d4b3
--- /dev/null
@@ -0,0 +1,68 @@
+--- /dev/null
++++ b/arch/mips/ar231x/early_printk.c
+@@ -0,0 +1,44 @@
++/*
++ * This file is subject to the terms and conditions of the GNU General Public
++ * License.  See the file "COPYING" in the main directory of this archive
++ * for more details.
++ *
++ * Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
++ */
++
++#include <linux/mm.h>
++#include <linux/io.h>
++#include <linux/serial_reg.h>
++#include <asm/addrspace.h>
++
++#include <asm/mach-ar231x/ar2315_regs.h>
++#include <asm/mach-ar231x/ar5312_regs.h>
++#include "devices.h"
++
++static inline void prom_uart_wr(void __iomem *base, unsigned reg,
++                              unsigned char ch)
++{
++      __raw_writeb(ch, base + 4 * reg);
++}
++
++static inline unsigned char prom_uart_rr(void __iomem *base, unsigned reg)
++{
++      return __raw_readb(base + 4 * reg);
++}
++
++void prom_putchar(unsigned char ch)
++{
++      static void __iomem *base;
++
++      if (unlikely(base == NULL)) {
++              if (is_2315())
++                      base = (void __iomem *)(KSEG1ADDR(AR2315_UART0));
++              else
++                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
++      }
++
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      prom_uart_wr(base, UART_TX, ch);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++}
++
+--- a/arch/mips/ar231x/Makefile
++++ b/arch/mips/ar231x/Makefile
+@@ -9,5 +9,8 @@
+ #
+ obj-y += board.o prom.o devices.o
++
++obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
++
+ obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
+ obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -70,6 +70,7 @@ config ATHEROS_AR231X
+       select SYS_SUPPORTS_BIG_ENDIAN
+       select SYS_SUPPORTS_32BIT_KERNEL
+       select GENERIC_GPIO
++      select SYS_HAS_EARLY_PRINTK
+       help
+         Support for AR231x and AR531x based boards
index 9b76dfee46c1c1986abb97f3be95f880f07115c8..3f5e6b4528b0b051dfba35cf3089d5b7d8df1e09 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/ar231x/Makefile
 +++ b/arch/mips/ar231x/Makefile
-@@ -11,3 +11,4 @@
- obj-y += board.o prom.o devices.o
+@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
  obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
  obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 +obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
index 79d4446fea237e1c9d0726eb4f30fd4a8b0cf2a4..3c91818146cf9001fcdc191915bd8612d08481f2 100644 (file)
@@ -6,9 +6,9 @@
  
 -obj-y += board.o prom.o devices.o
 +obj-y += board.o prom.o devices.o reset.o
- obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
- obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
- obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
 --- /dev/null
 +++ b/arch/mips/ar231x/reset.c
 @@ -0,0 +1,160 @@
diff --git a/target/linux/atheros/patches-2.6.31/101-early-printk-support.patch b/target/linux/atheros/patches-2.6.31/101-early-printk-support.patch
new file mode 100644 (file)
index 0000000..3536ca8
--- /dev/null
@@ -0,0 +1,68 @@
+--- /dev/null
++++ b/arch/mips/ar231x/early_printk.c
+@@ -0,0 +1,44 @@
++/*
++ * This file is subject to the terms and conditions of the GNU General Public
++ * License.  See the file "COPYING" in the main directory of this archive
++ * for more details.
++ *
++ * Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
++ */
++
++#include <linux/mm.h>
++#include <linux/io.h>
++#include <linux/serial_reg.h>
++#include <asm/addrspace.h>
++
++#include <asm/mach-ar231x/ar2315_regs.h>
++#include <asm/mach-ar231x/ar5312_regs.h>
++#include "devices.h"
++
++static inline void prom_uart_wr(void __iomem *base, unsigned reg,
++                              unsigned char ch)
++{
++      __raw_writeb(ch, base + 4 * reg);
++}
++
++static inline unsigned char prom_uart_rr(void __iomem *base, unsigned reg)
++{
++      return __raw_readb(base + 4 * reg);
++}
++
++void prom_putchar(unsigned char ch)
++{
++      static void __iomem *base;
++
++      if (unlikely(base == NULL)) {
++              if (is_2315())
++                      base = (void __iomem *)(KSEG1ADDR(AR2315_UART0));
++              else
++                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
++      }
++
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      prom_uart_wr(base, UART_TX, ch);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++}
++
+--- a/arch/mips/ar231x/Makefile
++++ b/arch/mips/ar231x/Makefile
+@@ -9,5 +9,8 @@
+ #
+ obj-y += board.o prom.o devices.o
++
++obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
++
+ obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
+ obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -90,6 +90,7 @@ config ATHEROS_AR231X
+       select SYS_SUPPORTS_BIG_ENDIAN
+       select SYS_SUPPORTS_32BIT_KERNEL
+       select GENERIC_GPIO
++      select SYS_HAS_EARLY_PRINTK
+       help
+         Support for AR231x and AR531x based boards
index 9b76dfee46c1c1986abb97f3be95f880f07115c8..3f5e6b4528b0b051dfba35cf3089d5b7d8df1e09 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/ar231x/Makefile
 +++ b/arch/mips/ar231x/Makefile
-@@ -11,3 +11,4 @@
- obj-y += board.o prom.o devices.o
+@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
  obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
  obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 +obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
index 79d4446fea237e1c9d0726eb4f30fd4a8b0cf2a4..3c91818146cf9001fcdc191915bd8612d08481f2 100644 (file)
@@ -6,9 +6,9 @@
  
 -obj-y += board.o prom.o devices.o
 +obj-y += board.o prom.o devices.o reset.o
- obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
- obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
- obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
 --- /dev/null
 +++ b/arch/mips/ar231x/reset.c
 @@ -0,0 +1,160 @@
diff --git a/target/linux/atheros/patches-2.6.32/101-early-printk-support.patch b/target/linux/atheros/patches-2.6.32/101-early-printk-support.patch
new file mode 100644 (file)
index 0000000..b52471a
--- /dev/null
@@ -0,0 +1,68 @@
+--- /dev/null
++++ b/arch/mips/ar231x/early_printk.c
+@@ -0,0 +1,44 @@
++/*
++ * This file is subject to the terms and conditions of the GNU General Public
++ * License.  See the file "COPYING" in the main directory of this archive
++ * for more details.
++ *
++ * Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
++ */
++
++#include <linux/mm.h>
++#include <linux/io.h>
++#include <linux/serial_reg.h>
++#include <asm/addrspace.h>
++
++#include <asm/mach-ar231x/ar2315_regs.h>
++#include <asm/mach-ar231x/ar5312_regs.h>
++#include "devices.h"
++
++static inline void prom_uart_wr(void __iomem *base, unsigned reg,
++                              unsigned char ch)
++{
++      __raw_writeb(ch, base + 4 * reg);
++}
++
++static inline unsigned char prom_uart_rr(void __iomem *base, unsigned reg)
++{
++      return __raw_readb(base + 4 * reg);
++}
++
++void prom_putchar(unsigned char ch)
++{
++      static void __iomem *base;
++
++      if (unlikely(base == NULL)) {
++              if (is_2315())
++                      base = (void __iomem *)(KSEG1ADDR(AR2315_UART0));
++              else
++                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
++      }
++
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      prom_uart_wr(base, UART_TX, ch);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++}
++
+--- a/arch/mips/ar231x/Makefile
++++ b/arch/mips/ar231x/Makefile
+@@ -9,5 +9,8 @@
+ #
+ obj-y += board.o prom.o devices.o
++
++obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
++
+ obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
+ obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -106,6 +106,7 @@ config ATHEROS_AR231X
+       select SYS_SUPPORTS_BIG_ENDIAN
+       select SYS_SUPPORTS_32BIT_KERNEL
+       select GENERIC_GPIO
++      select SYS_HAS_EARLY_PRINTK
+       help
+         Support for AR231x and AR531x based boards
index 9b76dfee46c1c1986abb97f3be95f880f07115c8..3f5e6b4528b0b051dfba35cf3089d5b7d8df1e09 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/ar231x/Makefile
 +++ b/arch/mips/ar231x/Makefile
-@@ -11,3 +11,4 @@
- obj-y += board.o prom.o devices.o
+@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
  obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
  obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 +obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
index 79d4446fea237e1c9d0726eb4f30fd4a8b0cf2a4..3c91818146cf9001fcdc191915bd8612d08481f2 100644 (file)
@@ -6,9 +6,9 @@
  
 -obj-y += board.o prom.o devices.o
 +obj-y += board.o prom.o devices.o reset.o
- obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
- obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
- obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
 --- /dev/null
 +++ b/arch/mips/ar231x/reset.c
 @@ -0,0 +1,160 @@
diff --git a/target/linux/atheros/patches-2.6.33/101-early-printk-support.patch b/target/linux/atheros/patches-2.6.33/101-early-printk-support.patch
new file mode 100644 (file)
index 0000000..8feec4c
--- /dev/null
@@ -0,0 +1,68 @@
+--- /dev/null
++++ b/arch/mips/ar231x/early_printk.c
+@@ -0,0 +1,44 @@
++/*
++ * This file is subject to the terms and conditions of the GNU General Public
++ * License.  See the file "COPYING" in the main directory of this archive
++ * for more details.
++ *
++ * Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
++ */
++
++#include <linux/mm.h>
++#include <linux/io.h>
++#include <linux/serial_reg.h>
++#include <asm/addrspace.h>
++
++#include <asm/mach-ar231x/ar2315_regs.h>
++#include <asm/mach-ar231x/ar5312_regs.h>
++#include "devices.h"
++
++static inline void prom_uart_wr(void __iomem *base, unsigned reg,
++                              unsigned char ch)
++{
++      __raw_writeb(ch, base + 4 * reg);
++}
++
++static inline unsigned char prom_uart_rr(void __iomem *base, unsigned reg)
++{
++      return __raw_readb(base + 4 * reg);
++}
++
++void prom_putchar(unsigned char ch)
++{
++      static void __iomem *base;
++
++      if (unlikely(base == NULL)) {
++              if (is_2315())
++                      base = (void __iomem *)(KSEG1ADDR(AR2315_UART0));
++              else
++                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
++      }
++
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      prom_uart_wr(base, UART_TX, ch);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++}
++
+--- a/arch/mips/ar231x/Makefile
++++ b/arch/mips/ar231x/Makefile
+@@ -9,5 +9,8 @@
+ #
+ obj-y += board.o prom.o devices.o
++
++obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
++
+ obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
+ obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -94,6 +94,7 @@ config ATHEROS_AR231X
+       select SYS_SUPPORTS_BIG_ENDIAN
+       select SYS_SUPPORTS_32BIT_KERNEL
+       select GENERIC_GPIO
++      select SYS_HAS_EARLY_PRINTK
+       help
+         Support for AR231x and AR531x based boards
index 9b76dfee46c1c1986abb97f3be95f880f07115c8..3f5e6b4528b0b051dfba35cf3089d5b7d8df1e09 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/ar231x/Makefile
 +++ b/arch/mips/ar231x/Makefile
-@@ -11,3 +11,4 @@
- obj-y += board.o prom.o devices.o
+@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
  obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
  obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 +obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
index 79d4446fea237e1c9d0726eb4f30fd4a8b0cf2a4..3c91818146cf9001fcdc191915bd8612d08481f2 100644 (file)
@@ -6,9 +6,9 @@
  
 -obj-y += board.o prom.o devices.o
 +obj-y += board.o prom.o devices.o reset.o
- obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
- obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
- obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
 --- /dev/null
 +++ b/arch/mips/ar231x/reset.c
 @@ -0,0 +1,160 @@