[packages/boost] use '--without-*' instead of '--with-*'
authorMirko Vogt <mirko@openwrt.org>
Tue, 10 Apr 2012 19:02:26 +0000 (19:02 +0000)
committerMirko Vogt <mirko@openwrt.org>
Tue, 10 Apr 2012 19:02:26 +0000 (19:02 +0000)
When just selecting 'boost' - which only stages the header files - no '--with-*'-option is passed.
This however leads the configure script of boost to build the whole boost-suite which is not intended.

SVN-Revision: 31245

libs/boost/Makefile

index dad50dd1e9d9749ad17afe2406590e872862645a..7dfcd68b2c9a8f4a7c561ca73f620cf0349f932f 100644 (file)
@@ -160,21 +160,21 @@ define Build/Compile
                        --toolset=gcc --build-type=minimal --layout=system \
                        --disable-long-double \
                        $(CONFIGURE_ARGS) \
-                       $(if $(CONFIG_PACKAGE_boost-date_time),--with-date_time) \
-                       $(if $(CONFIG_PACKAGE_boost-filesystem),--with-filesystem) \
-                       $(if $(CONFIG_PACKAGE_boost-graph),--with-graph) \
-                       $(if $(CONFIG_PACKAGE_boost-iostreams),--with-iostreams) \
-                       $(if $(CONFIG_PACKAGE_boost-math),--with-math) \
-                       $(if $(CONFIG_PACKAGE_boost-mpi),--with-mpi) \
-                       $(if $(CONFIG_PACKAGE_boost-program_options),--with-program_options) \
-                       $(if $(CONFIG_PACKAGE_boost-python),--with-python) \
-                       $(if $(CONFIG_PACKAGE_boost-regex),--with-regex) \
-                       $(if $(CONFIG_PACKAGE_boost-serialization),--with-serialization) \
-                       $(if $(CONFIG_PACKAGE_boost-signals),--with-signals) \
-                       $(if $(CONFIG_PACKAGE_boost-system),--with-system) \
-                       $(if $(CONFIG_PACKAGE_boost-test),--with-test) \
-                       $(if $(CONFIG_PACKAGE_boost-thread),--with-thread) \
-                       $(if $(CONFIG_PACKAGE_boost-wave),--with-wave) \
+                       $(if $(CONFIG_PACKAGE_boost-date_time),,--without-date_time) \
+                       $(if $(CONFIG_PACKAGE_boost-filesystem),,--without-filesystem) \
+                       $(if $(CONFIG_PACKAGE_boost-graph),,--without-graph) \
+                       $(if $(CONFIG_PACKAGE_boost-iostreams),,--without-iostreams) \
+                       $(if $(CONFIG_PACKAGE_boost-math),,--without-math) \
+                       $(if $(CONFIG_PACKAGE_boost-mpi),,--without-mpi) \
+                       $(if $(CONFIG_PACKAGE_boost-program_options),,--without-program_options) \
+                       $(if $(CONFIG_PACKAGE_boost-python),,--without-python) \
+                       $(if $(CONFIG_PACKAGE_boost-regex),,--without-regex) \
+                       $(if $(CONFIG_PACKAGE_boost-serialization),,--without-serialization) \
+                       $(if $(CONFIG_PACKAGE_boost-signals),,--without-signals) \
+                       $(if $(CONFIG_PACKAGE_boost-system),,--without-system) \
+                       $(if $(CONFIG_PACKAGE_boost-test),,--without-test) \
+                       $(if $(CONFIG_PACKAGE_boost-thread),,--without-thread) \
+                       $(if $(CONFIG_PACKAGE_boost-wave),,--without-wave) \
                        \
                        $(if $(CONFIG_PACKAGE_boost-iostreams),-sNO_BZIP2=1 -sZLIB_INCLUDE=$(STAGING_DIR)/usr/include \
                                -sZLIB_LIBPATH=$(STAGING_DIR)/usr/lib) \