imx6: put kernel and dtb into rootfs by default
authorJohn Crispin <john@openwrt.org>
Thu, 10 Jul 2014 22:02:24 +0000 (22:02 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 10 Jul 2014 22:02:24 +0000 (22:02 +0000)
this will make the rc1 images boot with the default config.

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41578

target/linux/imx6/image/Makefile

index 1c68cb0e40bbfc2b743c238c1bff943eba9f7d72..b07dd4fc8ca50b20eff8577b733dfc1c58a194df 100644 (file)
@@ -42,9 +42,9 @@ endef
 
 define Image/InstallKernel/Template
 
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
        $(INSTALL_DIR) $(TARGET_DIR)/boot
-   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
        $(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
        ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
    endif
@@ -59,7 +59,7 @@ define Image/InstallKernel/Template
    endif
  endif
 
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
        $(INSTALL_DIR) $(TARGET_DIR)/boot
        $(foreach dts,$(shell echo $(1)), \
                $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \