[package] libxslt: add InstallDev for libexslt
authorFlorian Fainelli <florian@openwrt.org>
Sat, 26 Feb 2011 14:51:16 +0000 (14:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 26 Feb 2011 14:51:16 +0000 (14:51 +0000)
The libxslt package does not InstallDev the exslt dev files when
libexslt package is selected.

Signed-off-by: Andrew Peebles <peebles@cortina-systems.com>
SVN-Revision: 25729

libs/libxslt/Makefile

index 13c0852306d05c67e160bc737fe4af547c06e5fb..e032941cca0730889ca19267b5c633816d69f50a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -68,8 +68,9 @@ CONFIGURE_ARGS+= \
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt $(1)/usr/lib \
+define Build/InstallDev/Xslt
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
+               $(1)/usr/include/libexslt $(1)/usr/lib \
                $(1)/usr/lib/pkgconfig $(2)/share/aclocal
 
        $(INSTALL_BIN) \
@@ -99,6 +100,26 @@ define Build/InstallDev
                $(2)/share/aclocal
 endef
 
+define Build/InstallDev/Exslt
+       $(INSTALL_DIR) $(1)/usr/include/libexslt $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/libexslt/* \
+               $(1)/usr/include/libexslt/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libexslt.{la,a,so*} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libexslt.pc \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Build/InstallDev
+        $(if $(CONFIG_PACKAGE_libxslt),$(call Build/InstallDev/Xslt,$(1)))
+        $(if $(CONFIG_PACKAGE_libexslt),$(call Build/InstallDev/Exslt,$(1)))
+endef
+
 define Package/libxslt/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) \