[buildroot] make targets provide their KERNELNAME
authorFlorian Fainelli <florian@openwrt.org>
Mon, 8 Nov 2010 07:31:25 +0000 (07:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 8 Nov 2010 07:31:25 +0000 (07:31 +0000)
SVN-Revision: 23919

include/kernel-defaults.mk
target/linux/avr32/Makefile
target/linux/rdc/Makefile
target/linux/x86/Makefile

index 5312ad49818f82ae35f73bbff206e84fe1e77aa4..312664ab7a4513d23ba8a24db6ad1592f2744b7b 100644 (file)
@@ -6,15 +6,6 @@
 #
 
 KERNELNAME=
 #
 
 KERNELNAME=
-ifneq (,$(findstring x86,$(BOARD)))
-  KERNELNAME="bzImage"
-endif
-ifneq (,$(findstring rdc,$(BOARD)))
-  KERNELNAME="bzImage"
-endif
-ifneq (,$(findstring avr32,$(BOARD)))
-  KERNELNAME="uImage"
-endif
 
 KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
        CROSS_COMPILE="$(KERNEL_CROSS)" \
 
 KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
        CROSS_COMPILE="$(KERNEL_CROSS)" \
index 62d249610e29c6052292fc4fb4ec5ccd0fd898ad..8c85be2fd5fb491bebbc422dddcd6ef7a0be7dde 100644 (file)
@@ -20,4 +20,6 @@ define Target/Description
   Build firmware images for ATNGW100 board
 endef
 
   Build firmware images for ATNGW100 board
 endef
 
+KERNELNAME:=uImage
+
 $(eval $(call BuildTarget))
 $(eval $(call BuildTarget))
index be5936cfcc6d79d54e9d07aa610c3054a13a0318..9099e783e58615c12d7c8d6b9c9bf0826302b244 100644 (file)
@@ -16,6 +16,8 @@ LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNELNAME:=bzImage
+
 DEFAULT_PACKAGES += wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
                    kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
                    kmod-rdc321x-wdt
 DEFAULT_PACKAGES += wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
                    kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
                    kmod-rdc321x-wdt
index 3cbed95426c0219d639f040185f8228d2b9a263a..fb365dd8ea9c7b2e3b11a1538125e0475d1c4131 100644 (file)
@@ -16,6 +16,8 @@ LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNELNAME:=bzImage
+
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \