[package] lsm: update to 0.131
authorFlorian Fainelli <florian@openwrt.org>
Mon, 13 Aug 2012 14:08:30 +0000 (14:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 13 Aug 2012 14:08:30 +0000 (14:08 +0000)
his patch updates link state monitor (lsm) to release 0.131,
add sample connections.conf and update lsm.conf and lsm_script

Signed-off-by: Edy Corak <info@loenshotel.de>
SVN-Revision: 33166

net/lsm/Makefile
net/lsm/files/connections.conf [new file with mode: 0644]
net/lsm/files/lsm.conf
net/lsm/files/lsm_script

index 864327de565bbad18112d54df42304761d82dea9..dbbf389259e67e2ef53d2d43f5074c9aafd86af1 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lsm
-PKG_VERSION:=0.60
-PKG_RELEASE:=3
+PKG_VERSION:=0.131
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://lsm.foobar.fi/download
-PKG_MD5SUM:=f4748308c0a1caa98d7e756778954116
+PKG_MD5SUM:=c3ff15f5e0d3988a1a45f35392639d40
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -48,12 +48,14 @@ define Package/lsm/install
        $(INSTALL_DIR) $(1)/etc/lsm
        $(INSTALL_DIR) $(1)/etc/lsm/script.d
        $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DATA) ./files/connections.conf $(1)/etc/lsm/connections.conf
        $(INSTALL_DATA) ./files/lsm.conf $(1)/etc/lsm/lsm.conf
        $(INSTALL_BIN) ./files/lsm_script $(1)/etc/lsm/script
        $(INSTALL_BIN) ./files/lsm.init $(1)/etc/init.d/lsm
 endef
 
 define Package/lsm/conffiles
+/etc/lsm/connections.conf
 /etc/lsm/lsm.conf
 endef
 
diff --git a/net/lsm/files/connections.conf b/net/lsm/files/connections.conf
new file mode 100644 (file)
index 0000000..087a895
--- /dev/null
@@ -0,0 +1,13 @@
+connection {
+   name=Provider1
+   checkip=1.1.1.1
+   device=pppoe-wan
+   ttl=2
+}
+
+connection {
+   name=Provider2
+   checkip=2.2.2.2
+   device=eth0.2
+   ttl=1
+}
index 16f9d04ad518e713254215404b51a4e9f37ec2d5..ca733728cdf41eff93c6474bbb3a6ed94bf62037 100644 (file)
@@ -1,4 +1,3 @@
-
 #
 # (C) 2009 Mika Ilmaranta <ilmis at nullnet.fi>
 #
@@ -12,7 +11,7 @@
 #debug=10
 #debug=9
 debug=8
-reopen_on_enodev=1
+reopen_on_enodev=1
 
 #
 # Defaults for the connection entries
@@ -21,7 +20,7 @@ defaults {
   name=defaults
   checkip=127.0.0.1
   eventscript=/etc/lsm/script
-  max_packet_loss=15
+  max_packet_loss=20
   max_successive_pkts_lost=7
   min_packet_loss=5
   min_successive_pkts_rcvd=10
index 61895b2d636178035f140f20350b8b762a244544..a373b311b524546da22ef6808712d4d74c8cec0e 100644 (file)
@@ -1,14 +1,11 @@
 #!/bin/sh
 #
-# (C) 2009 Mika Ilmaranta <ilmis at nullnet.fi>
+# (C) 2009 Mika Ilmaranta <ilmis@nullnet.fi>
+# (C) 2009 Tom Eastep <teastep@shorewall.net>
 #
 # License: GPLv2
 #
 
-#
-# default event handling script
-#
-
 DATE=$(/bin/date)
 
 STATE=${1}
@@ -25,42 +22,56 @@ CONS_WAIT=${11}
 CONS_MISS=${12}
 AVG_RTT=${13}
 
-cat <<EOM | mail -s "LSM: ${NAME} ${STATE}, IP ${CHECKIP}" ${WARN_EMAIL}
+if [ -f /usr/share/shorewall-lite/lib.base ]; then
+    VARDIR=/etc/shorewall-lite/state
+    STATEDIR=/etc/shorewall-lite
+else
+    VARDIR=/var/lib/shorewall
+    STATEDIR=/etc/shorewall
+fi
+
+[ -f ${STATEDIR}/vardir ] && . ${STATEDIR}/vardir
+
+cat <<EOM | ssmtp ${WARN_EMAIL}
+Subject: "LSM: ${NAME} ${STATE}, DEV ${DEVICE}"
 
 Hi,
 
 Your connection ${NAME} has changed it's state to ${STATE} at ${DATE}.
 
 Following parameters were passed:
+
 newstate     = ${STATE}
 name         = ${NAME}
 checkip      = ${CHECKIP}
 device       = ${DEVICE}
 warn_email   = ${WARN_EMAIL}
 
-Packet statuses:
+Packet counters:
+
 replied      = ${REPLIED} packets replied
 waiting      = ${WAITING} packets waiting for reply
-timeout      = ${TIMEOUT} packets that have timeout (= packet loss)
+timeout      = ${TIMEOUT} packets that have timeout (= packet loss)
 reply_late   = ${REPLY_LATE} packets that received a reply after timeout
 cons_rcvd    = ${CONS_RCVD} consecutively received replies in sequence
 cons_wait    = ${CONS_WAIT} consecutive packets waiting for reply
 cons_miss    = ${CONS_MISS} consecutive packets that have timed out
-avg_rtt      = ${AVG_RTT} average rtt [usec], calculated from received packets
+avg_rtt      = ${AVG_RTT} average rtt, notice that waiting and timed out packets have rtt = 0 when calculating this
 
-BR,
-Your LSM installation
+Your LSM Daemon
 
 EOM
 
-cd /etc/lsm/script.d/
-for script in $(ls); do
-    if [ ! -x $script ]; then
-        continue
-    fi
-    ./$script "$@"
-done
+if [ ${STATE} = up ]; then
+    echo 0 > ${VARDIR}/${DEVICE}.status # Uncomment this line if you are running Shorewall 4.4.x or earlier
+    ${VARDIR}/firewall enable ${DEVICE}
+else
+    echo 1 > ${VARDIR}/${DEVICE}.status # Uncomment this line if you are running Shorewall 4.4.x or earlier
+    ${VARDIR}/firewall disable ${DEVICE}
+fi
+
+/sbin/shorewall-lite show routing > /var/log/lsm
 
-exit 0;
+exit 0
 
 #EOF