[kernel] refresh generic 2.6.26 patches
authorGabor Juhos <juhosg@openwrt.org>
Mon, 2 Jun 2008 19:49:28 +0000 (19:49 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 2 Jun 2008 19:49:28 +0000 (19:49 +0000)
SVN-Revision: 11336

28 files changed:
target/linux/generic-2.6/patches-2.6.26/001-squashfs.patch
target/linux/generic-2.6/patches-2.6.26/004-extra_optimization.patch
target/linux/generic-2.6/patches-2.6.26/007-samsung_flash.patch
target/linux/generic-2.6/patches-2.6.26/009-revert_intel_flash_breakage.patch
target/linux/generic-2.6/patches-2.6.26/065-rootfs_split.patch
target/linux/generic-2.6/patches-2.6.26/100-netfilter_layer7_2.17.patch
target/linux/generic-2.6/patches-2.6.26/110-ipp2p_0.8.1rc1.patch
target/linux/generic-2.6/patches-2.6.26/130-netfilter_ipset.patch
target/linux/generic-2.6/patches-2.6.26/140-netfilter_time.patch
target/linux/generic-2.6/patches-2.6.26/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch
target/linux/generic-2.6/patches-2.6.26/171-netfilter_tarpit.patch
target/linux/generic-2.6/patches-2.6.26/180-netfilter_depends.patch
target/linux/generic-2.6/patches-2.6.26/190-netfilter_rtsp.patch
target/linux/generic-2.6/patches-2.6.26/204-jffs2_eofdetect.patch
target/linux/generic-2.6/patches-2.6.26/209-mini_fo.patch
target/linux/generic-2.6/patches-2.6.26/213-kobject_uevent.patch
target/linux/generic-2.6/patches-2.6.26/400-ledtrig_morse.patch
target/linux/generic-2.6/patches-2.6.26/401-led_alix.patch
target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch
target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch
target/linux/generic-2.6/patches-2.6.26/600-phy_extension.patch
target/linux/generic-2.6/patches-2.6.26/610-phy_detect.patch
target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch
target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
target/linux/generic-2.6/patches-2.6.26/840-unable_to_open_console.patch
target/linux/generic-2.6/patches-2.6.26/902-darwin_scripts_include.patch
target/linux/generic-2.6/patches-2.6.26/950-revert_xt_sctp_simplify.patch

index 4f55eb539b620bc0c3ce1d6c158ec07129c8bc66..ab854bba4ba896c903c5cc840212c6d647df8408 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/Kconfig
 +++ b/fs/Kconfig
-@@ -1367,6 +1367,71 @@
+@@ -1395,6 +1395,71 @@
  
          If unsure, say N.
  
index d3898f1fc6f9265c9a14654e23377be9d7a6e943..6dc316e6fbbe5995cc2f6585b19f94374ae6f5c0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -533,6 +533,9 @@
+@@ -537,6 +537,9 @@
  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
  CHECKFLAGS     += $(NOSTDINC_FLAGS)
  
index f1279c29f81ac555534a9dc9147236e58b8fafc9..71e47a55c8caa3e648fcffd8a16d4b45cdd91288 100644 (file)
@@ -8,7 +8,7 @@
  
  static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
  static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -298,12 +299,19 @@
+@@ -324,12 +325,19 @@
  
                if (extp->MajorVersion != '1' ||
                    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
index d2c1dc5d4b130d096ddc674599b15b2f8394e741..21c2bde58cfb8d668ea2386479ecfde67798e1b3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0001.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -1008,7 +1008,7 @@
+@@ -1010,7 +1010,7 @@
  
  static int __xipram xip_wait_for_operation(
                struct map_info *map, struct flchip *chip,
@@ -9,7 +9,7 @@
  {
        struct cfi_private *cfi = map->fldrv_priv;
        struct cfi_pri_intelext *cfip = cfi->cmdset_priv;
-@@ -1017,7 +1017,7 @@
+@@ -1019,7 +1019,7 @@
        flstate_t oldstate, newstate;
  
                start = xip_currtime();
@@ -18,7 +18,7 @@
        if (usec == 0)
                usec = 500000;
        done = 0;
-@@ -1127,8 +1127,8 @@
+@@ -1129,8 +1129,8 @@
  #define XIP_INVAL_CACHED_RANGE(map, from, size)  \
        INVALIDATE_CACHED_RANGE(map, from, size)
  
@@ -29,7 +29,7 @@
  
  #else
  
-@@ -1140,65 +1140,65 @@
+@@ -1142,65 +1142,65 @@
  static int inval_cache_and_wait_for_operation(
                struct map_info *map, struct flchip *chip,
                unsigned long cmd_adr, unsigned long inval_adr, int inval_len,
        /* Done and happy. */
        chip->state = FL_STATUS;
        return 0;
-@@ -1207,7 +1207,8 @@
+@@ -1209,7 +1209,8 @@
  #endif
  
  #define WAIT_TIMEOUT(map, chip, adr, udelay) \
  
  
  static int do_point_onechip (struct map_info *map, struct flchip *chip, loff_t adr, size_t len)
-@@ -1438,7 +1439,7 @@
+@@ -1443,7 +1444,7 @@
  
        ret = INVAL_CACHE_AND_WAIT(map, chip, adr,
                                   adr, map_bankwidth(map),
        if (ret) {
                xip_enable(map, chip, adr);
                printk(KERN_ERR "%s: word write error (status timeout)\n", map->name);
-@@ -1678,7 +1679,7 @@
+@@ -1683,7 +1684,7 @@
  
        ret = INVAL_CACHE_AND_WAIT(map, chip, cmd_adr,
                                   initial_adr, initial_len,
        if (ret) {
                map_write(map, CMD(0x70), cmd_adr);
                chip->state = FL_STATUS;
-@@ -1813,7 +1814,7 @@
+@@ -1818,7 +1819,7 @@
  
        ret = INVAL_CACHE_AND_WAIT(map, chip, adr,
                                   adr, len,
index 62a7e252e3c768284978b1a9f38d4465a60f4740..069b243990c62dcbeeb9fe3b0c6233dda65f5458 100644 (file)
  struct mtd_info {
        u_char type;
        u_int32_t flags;
-@@ -211,6 +212,9 @@
+@@ -213,6 +214,9 @@
        struct module *owner;
        int usecount;
  
index 917adc51a0a0544337a6c59e56066ea1a5a99041..451dfe9c1ba426d8b9cd5ba82bf3db5d1395733e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -735,6 +735,27 @@
+@@ -749,6 +749,27 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -30,7 +30,7 @@
        depends on NETFILTER_XTABLES
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -77,6 +77,7 @@
+@@ -78,6 +78,7 @@
  obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
 +}
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -210,6 +210,14 @@
+@@ -207,6 +207,14 @@
         * too. */
        nf_ct_remove_expectations(ct);
  
                BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -181,7 +181,12 @@
+@@ -174,7 +174,12 @@
                return -ENOSPC;
  #endif
  
index cd1abfaf6da2c547d33abbb1645cb8c25d0cf8b3..053f1c7e13102ddd016b02a72d33bd9cf92b3fff 100644 (file)
        depends on IP_NF_IPTABLES
 --- a/net/ipv4/netfilter/Makefile
 +++ b/net/ipv4/netfilter/Makefile
-@@ -47,6 +47,8 @@
+@@ -50,6 +50,8 @@
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  
index 88e33d5cff5fb08a9f28513272f0e54ce0edfe6a..d3f5a5957fee731bb00d906104d902cc0578019c 100644 (file)
 +module_exit(ipt_SET_fini);
 --- a/net/ipv4/netfilter/Kconfig
 +++ b/net/ipv4/netfilter/Kconfig
-@@ -385,5 +385,122 @@
+@@ -401,5 +401,122 @@
          Allows altering the ARP packet payload: source and destination
          hardware and network addresses.
  
  
 --- a/net/ipv4/netfilter/Makefile
 +++ b/net/ipv4/netfilter/Makefile
-@@ -46,6 +46,7 @@
+@@ -49,6 +49,7 @@
  obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn.o
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  
  obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
  
-@@ -59,6 +60,18 @@
+@@ -62,6 +63,18 @@
  obj-$(CONFIG_IP_NF_TARGET_REJECT) += ipt_REJECT.o
  obj-$(CONFIG_IP_NF_TARGET_TTL) += ipt_TTL.o
  obj-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG.o
index ba6b5dc3202fef3e0ee6b4e2786541dbb357b4de..821c0cef5724cdb1d055bf72e6c0567a3e32af44 100644 (file)
        depends on IP_NF_IPTABLES
 --- a/net/ipv4/netfilter/Makefile
 +++ b/net/ipv4/netfilter/Makefile
-@@ -47,6 +47,7 @@
+@@ -50,6 +50,7 @@
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  obj-$(CONFIG_IP_NF_MATCH_SET) += ipt_set.o
index e5db1d8212542e8bd940d59f82ad0da9506d6bcd..1829d299632c28393c406a460fa769282dc1913c 100644 (file)
        select CRC32
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
-@@ -143,6 +143,7 @@
+@@ -142,6 +142,7 @@
  obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
  
  obj-$(CONFIG_DUMMY) += dummy.o
 +#endif /* _IP6T_IMQ_H */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -296,6 +296,10 @@
+@@ -300,6 +300,10 @@
        struct nf_conntrack     *nfct;
        struct sk_buff          *nfct_reasm;
  #endif
  #ifdef CONFIG_BRIDGE_NETFILTER
        struct nf_bridge_info   *nf_bridge;
  #endif
-@@ -1736,6 +1740,10 @@
+@@ -1633,6 +1637,10 @@
        dst->nfct_reasm = src->nfct_reasm;
        nf_conntrack_get_reasm(src->nfct_reasm);
  #endif
  #include <linux/proc_fs.h>
  #include <linux/seq_file.h>
  #include <linux/stat.h>
-@@ -1537,7 +1540,11 @@
+@@ -1545,7 +1548,11 @@
  int dev_hard_start_xmit(struct sk_buff *skb, struct net_device *dev)
  {
        if (likely(!skb->next)) {
        depends on IP_NF_FILTER
 --- a/net/ipv4/netfilter/Makefile
 +++ b/net/ipv4/netfilter/Makefile
-@@ -55,6 +55,7 @@
+@@ -58,6 +58,7 @@
  obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
  obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
  obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LOG.o
index d059973f2f3027a90bb88bdff93fbb347854a3a3..df805f528326cef73d80cb46b7faefc93fcae7e8 100644 (file)
@@ -95,7 +95,7 @@
 +#define xt_request_find_match xt_request_find_match_lo
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -276,6 +276,14 @@
+@@ -288,6 +288,14 @@
  
  # alphabetically ordered list of targets
  
  config NETFILTER_XT_TARGET_CLASSIFY
        tristate '"CLASSIFY" target support'
        depends on NETFILTER_XTABLES
-@@ -305,6 +313,14 @@
+@@ -317,6 +325,14 @@
          <file:Documentation/kbuild/modules.txt>.  The module will be called
          ipt_CONNMARK.ko.  If unsure, say `N'.
  
  config NETFILTER_XT_TARGET_DSCP
        tristate '"DSCP" and "TOS" target support'
        depends on NETFILTER_XTABLES
-@@ -640,6 +656,14 @@
+@@ -653,6 +669,14 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
        depends on NETFILTER_XTABLES
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -50,6 +50,8 @@
+@@ -51,6 +51,8 @@
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP) += xt_TCPOPTSTRIP.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
  
  # matches
  obj-$(CONFIG_NETFILTER_XT_MATCH_COMMENT) += xt_comment.o
-@@ -83,3 +85,4 @@
+@@ -84,3 +86,4 @@
  obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_TIME) += xt_time.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_U32) += xt_u32.o
 +MODULE_ALIAS("ipt_portscan");
 --- a/drivers/char/random.c
 +++ b/drivers/char/random.c
-@@ -1563,6 +1563,8 @@
+@@ -1553,6 +1553,8 @@
        return seq;
  }
  
index 8575368699702a08f7d5f8834cbbece52e4e430f..24b334efe8f3f7eee586861d3c00d6ef940372e6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -437,6 +437,23 @@
+@@ -449,6 +449,23 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -26,7 +26,7 @@
        depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -47,6 +47,7 @@
+@@ -48,6 +48,7 @@
  obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_RATEEST) += xt_RATEEST.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
index dbdcf39e7b31763d02a8488efe16cc67b953f83c..63c81b273eee79aad341e19e0c1594e18d5d4563 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -145,7 +145,7 @@
+@@ -157,7 +157,7 @@
  
  config NF_CONNTRACK_H323
        tristate "H.323 protocol support"
@@ -9,7 +9,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -456,7 +456,7 @@
+@@ -468,7 +468,7 @@
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index ead8cb2be473c9f645ff4820e9b00ac1eaa4274a..c872189321e98e925b05dedad080d6fe6094c140 100644 (file)
  obj-$(CONFIG_NF_NAT_SNMP_BASIC) += nf_nat_snmp_basic.o
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -258,6 +258,16 @@
+@@ -270,6 +270,16 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
        depends on NF_CONNTRACK
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -32,6 +32,7 @@
+@@ -33,6 +33,7 @@
  obj-$(CONFIG_NF_CONNTRACK_SANE) += nf_conntrack_sane.o
  obj-$(CONFIG_NF_CONNTRACK_SIP) += nf_conntrack_sip.o
  obj-$(CONFIG_NF_CONNTRACK_TFTP) += nf_conntrack_tftp.o
  obj-$(CONFIG_NETFILTER_XTABLES) += x_tables.o xt_tcpudp.o
 --- a/net/ipv4/netfilter/Kconfig
 +++ b/net/ipv4/netfilter/Kconfig
-@@ -277,6 +277,11 @@
+@@ -304,6 +304,11 @@
        depends on IP_NF_IPTABLES && NF_CONNTRACK && NF_NAT
        default NF_NAT && NF_CONNTRACK_IRC
  
index 5053401f118509bddd6c4ce67fb4dce08b880820..de554ad01ff5bd90f3f4836db21c4b8e351c1cc8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/jffs2/build.c
 +++ b/fs/jffs2/build.c
-@@ -105,6 +105,17 @@
+@@ -111,6 +111,17 @@
        dbg_fsbuild("scanned flash completely\n");
        jffs2_dbg_dump_block_lists_nolock(c);
  
@@ -20,7 +20,7 @@
        /* Now scan the directory tree, increasing nlink according to every dirent found. */
 --- a/fs/jffs2/scan.c
 +++ b/fs/jffs2/scan.c
-@@ -142,9 +142,12 @@
+@@ -143,9 +143,12 @@
  
                /* reset summary info for next eraseblock scan */
                jffs2_sum_reset_collected(s);
@@ -36,7 +36,7 @@
  
                if (ret < 0)
                        goto out;
-@@ -545,6 +548,17 @@
+@@ -546,6 +549,17 @@
                        return err;
        }
  
index 9b585463b75cdc7071bf7148ede8068ccbb826e1..aa40112e5a9d43ad016979c77a0858d0e18a72bb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/Kconfig
 +++ b/fs/Kconfig
-@@ -1449,6 +1449,9 @@
+@@ -1477,6 +1477,9 @@
          To compile this as a module, choose M here: the module will be
          called freevxfs.  If unsure, say N.
  
index 27113667956abcd88758181974a6ccd892639d01..745068908294bf5d3185528a8db54f0e4c096777 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/kobject_uevent.c
 +++ b/lib/kobject_uevent.c
-@@ -27,7 +27,8 @@
+@@ -29,7 +29,8 @@
  char uevent_helper[UEVENT_HELPER_PATH_LEN] = CONFIG_UEVENT_HELPER_PATH;
  static DEFINE_SPINLOCK(sequence_lock);
  #if defined(CONFIG_NET)
@@ -10,7 +10,7 @@
  #endif
  
  /* the strings here must match the enum in include/linux/kobject.h */
-@@ -40,6 +41,18 @@
+@@ -42,6 +43,18 @@
        [KOBJ_OFFLINE] =        "offline",
  };
  
@@ -29,7 +29,7 @@
  /**
   * kobject_action_type - translate action string to numeric type
   *
-@@ -192,9 +205,7 @@
+@@ -194,9 +207,7 @@
                kobj->state_remove_uevent_sent = 1;
  
        /* we will send an event, so request a new sequence number */
index c17aa2f8640ccf740d31cdd7012d1d13334982b7..d7544fa0ee85f448aee4f8062b207c8fe35c0022 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -181,4 +181,8 @@
-         load average.
+@@ -190,4 +190,8 @@
+         This allows LEDs to be initialised in the ON state.
          If unsure, say Y.
  
 +config LEDS_TRIGGER_MORSE
@@ -11,7 +11,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -26,3 +26,4 @@
+@@ -27,3 +27,4 @@
  obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK)   += ledtrig-ide-disk.o
  obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)  += ledtrig-heartbeat.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index 721668304868985af3698dbddd08991d368cc361..1bec37ecba0d941a7715b3fc7bffe70ee8e541e1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -79,6 +79,12 @@
+@@ -77,6 +77,12 @@
        help
          This option enables support for the PCEngines WRAP programmable LEDs.
  
@@ -15,7 +15,7 @@
        depends on LEDS_CLASS && ARCH_H1940
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -14,6 +14,7 @@
+@@ -13,6 +13,7 @@
  obj-$(CONFIG_LEDS_AMS_DELTA)          += leds-ams-delta.o
  obj-$(CONFIG_LEDS_NET48XX)            += leds-net48xx.o
  obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o
index 6ae2cd7df5d4ac477e641ce7dbdfb91fe337f92a..29e6167250177b529f236a8c1e2c099cd83f07e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/input/misc/Kconfig
 +++ b/drivers/input/misc/Kconfig
-@@ -197,4 +197,20 @@
+@@ -198,4 +198,20 @@
          Say Y here if you want to support the built-in real time clock
          of the HP SDC controller.
  
index 5eecc61ae5477c2c4cf183c022a386bfd8a21839..5865521bfd5d968dd77c67ed79aef06bbb134e28 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/char/Kconfig
 +++ b/drivers/char/Kconfig
-@@ -955,6 +955,13 @@
+@@ -1002,6 +1002,13 @@
  
          If compiled as a module, it will be called cs5535_gpio.
  
@@ -16,7 +16,7 @@
        depends on CPU_VR41XX
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -94,6 +94,7 @@
+@@ -95,6 +95,7 @@
  obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
  obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
  obj-$(CONFIG_CS5535_GPIO)     += cs5535_gpio.o
index 6ac585eeff2ef39a83404155f7b7f0b9a7fa806d..ec0a402b66bbd8f247a82a1023517d2b5e8cf07e 100644 (file)
@@ -53,7 +53,7 @@
   * @phydev: the phy_device struct
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -399,6 +399,7 @@
+@@ -434,6 +434,7 @@
  void phy_stop_machine(struct phy_device *phydev);
  int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
  int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);
index 1b6f4c194ecbfc5896f6769ae1dc0f1cf68850cf..5cc9cd2895c84d83b9a5fedf14963c519067d2f0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/mdio_bus.c
 +++ b/drivers/net/phy/mdio_bus.c
-@@ -132,6 +132,9 @@
+@@ -135,6 +135,9 @@
        struct phy_device *phydev = to_phy_device(dev);
        struct phy_driver *phydrv = to_phy_driver(drv);
  
@@ -12,7 +12,7 @@
  }
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -325,6 +325,11 @@
+@@ -339,6 +339,11 @@
        u32 features;
        u32 flags;
  
index 22654db8fbc694f27c0ab3bf610c584b17305ffd..e52f11a29413df5cc50787c2fd71d86361a38c58 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -53,6 +53,18 @@
-       phy_device_free(to_phy_device(dev));
+@@ -143,6 +143,18 @@
  }
+ EXPORT_SYMBOL(phy_scan_fixups);
  
 +static int generic_receive_skb(struct sk_buff *skb)
 +{
@@ -19,7 +19,7 @@
  struct phy_device* phy_device_create(struct mii_bus *bus, int addr, int phy_id)
  {
        struct phy_device *dev;
-@@ -78,6 +90,8 @@
+@@ -168,6 +180,8 @@
        dev->bus = bus;
  
        dev->state = PHY_DOWN;
@@ -30,7 +30,7 @@
  
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -295,6 +295,17 @@
+@@ -309,6 +309,17 @@
        void (*adjust_link)(struct net_device *dev);
  
        void (*adjust_state)(struct net_device *dev);
@@ -50,7 +50,7 @@
  
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -595,6 +595,7 @@
+@@ -609,6 +609,7 @@
        void                    *ax25_ptr;      /* AX.25 specific data */
        struct wireless_dev     *ieee80211_ptr; /* IEEE 802.11 specific data,
                                                   assign before registering */
index 79ee43e16abff4e1b99122c3619e64dc4a7e02f7..e856dc120a6da2fdfb006591afda605635ca8962 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];    /* initially all NULL */
  static DEFINE_MUTEX(table_lock);
-@@ -904,7 +905,7 @@
+@@ -812,7 +813,7 @@
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1316,3 +1317,5 @@
+@@ -1226,3 +1227,5 @@
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 1289129a898fe41eb2d8d779bd59f6eafb96e674..ec13777dd3f07293ad24cc41023b17aef47c919b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -775,7 +775,7 @@
+@@ -803,7 +803,7 @@
        numa_default_policy();
  
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index 36b4d259f5340cb24e587de946c2d86a6738384a..5d454b8e017a97492cf68fb3bd3e50d525f07d56 100644 (file)
@@ -24,7 +24,7 @@
  static int is_typedef;
 --- a/scripts/kallsyms.c
 +++ b/scripts/kallsyms.c
-@@ -28,6 +28,35 @@
+@@ -22,6 +22,35 @@
  #include <stdlib.h>
  #include <string.h>
  #include <ctype.h>
index 6c8cdf1576991a971920bac59eb3027bd4133aa1..a4d9381b59e7e0df7558325b088ebff3eab2acdb 100644 (file)
@@ -1,5 +1,5 @@
---- linux-2.6.26-rc4/include/linux/netfilter/xt_sctp.h 2008-05-26 20:08:11.000000000 +0200
-+++ linux-2.6.26-rc4-owrt/include/linux/netfilter/xt_sctp.h    2008-06-02 13:30:15.000000000 +0200
+--- a/include/linux/netfilter/xt_sctp.h
++++ b/include/linux/netfilter/xt_sctp.h
 @@ -37,54 +37,68 @@
  
  #define SCTP_CHUNKMAP_SET(chunkmap, type)             \