Add wpa_supplicant package
authorNicolas Thill <nico@openwrt.org>
Mon, 23 May 2005 06:43:34 +0000 (06:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 23 May 2005 06:43:34 +0000 (06:43 +0000)
SVN-Revision: 1023

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/wpa_supplicant/Config.in [new file with mode: 0644]
openwrt/package/wpa_supplicant/Makefile [new file with mode: 0644]
openwrt/package/wpa_supplicant/files/config [new file with mode: 0644]
openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control [new file with mode: 0644]
openwrt/package/wpa_supplicant/patches/ldflags.patch [new file with mode: 0644]
openwrt/package/wpa_supplicant/patches/opt_cflags.patch [new file with mode: 0644]

index 3c6a2ba49974d775e9dc0e6fafb24910c95903bb..d83c2d246023ddcc9d775f68ac4d86bfefcf5758 100644 (file)
@@ -72,6 +72,7 @@ source "package/ulogd/Config.in"
 source "package/vsftpd/Config.in"
 source "package/wireless-tools/Config.in"
 source "package/wol/Config.in"
+source "package/wpa_supplicant/Config.in"
 source "package/wput/Config.in"
 source "package/xinetd/Config.in"
 
index c5a3c07096e80e78ad1d1e1d9e38f0ab29249325..c2b12f6a8bd4496b7fd60baea92b173e2c042ec0 100644 (file)
@@ -94,6 +94,7 @@ package-$(BR2_PACKAGE_USBUTILS) += usbutils
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
 package-$(BR2_PACKAGE_WIRELESS_TOOLS) += wireless-tools
 package-$(BR2_PACKAGE_WOL) += wol
+package-$(BR2_PACKAGE_WPA_SUPPLICANT) += wpa_supplicant
 package-$(BR2_PACKAGE_WPUT) += wput
 package-$(BR2_PACKAGE_XINETD) += xinetd
 package-$(BR2_PACKAGE_ZLIB) += zlib
@@ -133,6 +134,7 @@ siproxd-compile: libosip2-compile
 sipsak-compile: openssl-compile
 tcpdump-compile: libpcap-compile
 tinc-compile: zlib-compile openssl-compile lzo-compile
+wpa_supplicant-compile: openssl-compile
 
 asterisk-compile: openssl-compile
 ifneq ($(BR2_PACKAGE_ASTERISK_SPEEX),)
diff --git a/openwrt/package/wpa_supplicant/Config.in b/openwrt/package/wpa_supplicant/Config.in
new file mode 100644 (file)
index 0000000..efff583
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_WPA_SUPPLICANT
+       tristate "wpa_supplicant - WPA Supplicant with support for WPA and WPA2"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBOPENSSL
+       help
+         
+         WPA Supplicant with support for WPA and WPA2 (IEEE 802.11i / RSN).
+         Supplicant is the IEEE 802.1X/WPA component that is used in the client 
+         stations. It implements key negotiation with a WPA Authenticator and it 
+         controls the roaming and IEEE 802.11 authentication/association.
+         
+         http://hostap.epitest.fi/wpa_supplicant/
+         
+         Depends: openssl
+         
diff --git a/openwrt/package/wpa_supplicant/Makefile b/openwrt/package/wpa_supplicant/Makefile
new file mode 100644 (file)
index 0000000..3536508
--- /dev/null
@@ -0,0 +1,40 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wpa_supplicant
+PKG_VERSION:=0.3.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=
+
+PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WPA_SUPPLICANT,wpa-supplicant,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       cp -fp ./files/config $(PKG_BUILD_DIR)/.config
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CPPFLAGS="-I$(TOPDIR)/package/openwrt/include -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               OPT_FLAGS="$(TARGET_CFLAGS)" \
+               KERNEL=$(LINUX_DIR) \
+               all
+       touch $@
+
+$(IPKG_WPA_SUPPLICANT):
+       install -m0755 -d $(IDIR_WPA_SUPPLICANT)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/wpa_cli $(IDIR_WPA_SUPPLICANT)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/wpa_passphrase $(IDIR_WPA_SUPPLICANT)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/wpa_supplicant $(IDIR_WPA_SUPPLICANT)/usr/sbin/
+       $(RSTRIP) $(IDIR_WPA_SUPPLICANT)
+       $(IPKG_BUILD) $(IDIR_WPA_SUPPLICANT) $(PACKAGE_DIR)
diff --git a/openwrt/package/wpa_supplicant/files/config b/openwrt/package/wpa_supplicant/files/config
new file mode 100644 (file)
index 0000000..fe7d269
--- /dev/null
@@ -0,0 +1,14 @@
+# rather important
+CONFIG_DRIVER_BROADCOM=y
+CONFIG_IEEE8021X_EAPOL=y
+CONFIG_CTRL_IFACE=y
+
+# default
+CONFIG_EAP_PSK=y
+CONFIG_EAP_MD5=y
+
+# optional
+CONFIG_MSCHAPV2=y
+CONFIG_EAP_TLS=y
+CONFIG_EAP_PEAP=y
+CONFIG_EAP_TTLS=y
diff --git a/openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control b/openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control
new file mode 100644 (file)
index 0000000..ec78d71
--- /dev/null
@@ -0,0 +1,6 @@
+Package: wpa-supplicant
+Priority: optional
+Section: net
+Maintainer: Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/wpa_supplicant
+Description: WPA Supplicant with support for WPA and WPA2
diff --git a/openwrt/package/wpa_supplicant/patches/ldflags.patch b/openwrt/package/wpa_supplicant/patches/ldflags.patch
new file mode 100644 (file)
index 0000000..b8b6f66
--- /dev/null
@@ -0,0 +1,24 @@
+--- wpa_supplicant-0.3.8/Makefile.orig 2005-05-22 12:37:28.000000000 +0200
++++ wpa_supplicant-0.3.8/Makefile      2005-05-22 12:40:04.000000000 +0200
+@@ -304,7 +304,7 @@
+ OBJS += wpa_supplicant.o wpa.o l2_packet.o drivers.o
+ wpa_supplicant: .config $(OBJS)
+-      $(CC) -o wpa_supplicant $(OBJS) $(LIBS)
++      $(CC) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS)
+ eapol_test: .config $(OBJS_t)
+       $(CC) -o eapol_test $(OBJS_t) $(LIBS)
+@@ -313,10 +313,10 @@
+       $(CC) -o preauth_test $(OBJS_t2) $(LIBS)
+ wpa_passphrase: $(OBJS_p)
+-      $(CC) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
++      $(CC) $(LDFLAGS) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
+ wpa_cli: $(OBJS_c)
+-      $(CC) -o wpa_cli $(OBJS_c) $(LIBS_c)
++      $(CC) $(LDFLAGS) -o wpa_cli $(OBJS_c) $(LIBS_c)
+ win_if_list: win_if_list.c
+       $(CC) -o $@ win_if_list.c $(CFLAGS) $(LIBS_w)
diff --git a/openwrt/package/wpa_supplicant/patches/opt_cflags.patch b/openwrt/package/wpa_supplicant/patches/opt_cflags.patch
new file mode 100644 (file)
index 0000000..ec38b73
--- /dev/null
@@ -0,0 +1,12 @@
+--- wpa_supplicant-0.3.8/Makefile.orig 2005-02-14 02:55:47.000000000 +0100
++++ wpa_supplicant-0.3.8/Makefile      2005-05-21 21:06:03.000000000 +0200
+@@ -3,7 +3,8 @@
+ endif
+ ifndef CFLAGS
+-CFLAGS = -MMD -O2 -Wall -g
++OPT_FLAGS = -O2 -g
++CFLAGS = -MMD $(OPT_FLAGS) -Wall
+ endif
+ # Include directories for CVS version