brcm63xx: Add support for Huawei HG520v
authorJonas Gorski <jogo@openwrt.org>
Sun, 27 Jul 2014 17:44:56 +0000 (17:44 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 27 Jul 2014 17:44:56 +0000 (17:44 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 41851

target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.10/565-board_hw520.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch [new file with mode: 0644]

index 964f5baa2aa6e0e3c4a36c3996cbf33e03db5045..97ef3e82f2ccc9de48d21871dd5efa3b23b72a78 100755 (executable)
@@ -70,7 +70,8 @@ HW556*)
        ;;
 
 NB4-* |\
-DVG3810BN)
+DVG3810BN |\
+HW6358GW_B)
        ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
        ucidef_add_switch "eth1" "1" "1"
        ucidef_add_switch_vlan "eth1" "1" "0 1 2 3 4 5t"
index 1029fe36aa9285335b0d5877c52ae599c488e7f2..d5784db750df019cb7f536b3e7429cd568200e71 100755 (executable)
@@ -131,6 +131,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       HW6358GW_B)
+               status_led="HW520:green:net"
+               brcm63xx_has_reset_button="true"
+               ifname="eth0"
+               ;;
        NB6)
                brcm63xx_has_reset_button="true"
                ifname=eth0
index 680cf975dbdba80543879ea788f605eefa2e5c84..dbda363795a23e7bded3f4e2fd4a42378c520ed4 100755 (executable)
@@ -310,6 +310,9 @@ define Image/Build
        # T-Com Speedport W 500V
        $(call Image/Build/CFEFIXUP,$(1),96348GW,SPW500V,6348,SPW500V)
 
+       # Huawei HW520
+       $(call Image/Build/CFE,$(1),HW6358GW_B,6358,HW520,EchoLife_HG520v)
+
        #HW553
        $(call Image/Build/CFEHW553,$(1),HW553,6358,0x20000,HW553)
 
diff --git a/target/linux/brcm63xx/patches-3.10/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.10/565-board_hw520.patch
new file mode 100644 (file)
index 0000000..d1b1641
--- /dev/null
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -3428,6 +3428,49 @@ static struct board_info __initdata boar
+       .num_spis = ARRAY_SIZE(ct6373_spi_devices),
+ };
++static struct board_info __initdata board_HW520 = {
++      .name                           = "HW6358GW_B",
++      .expected_cpu_id                = 0x6358,
++
++      .has_uart0                      = 1,
++      .has_pci                        = 1,
++      .has_ohci0                      = 1,
++      .has_ehci0                      = 1,
++
++      .has_enet0                      = 1,
++      .enet0 = {
++              .has_phy                = 1,
++              .use_internal_phy       = 1,
++      },
++
++      .has_enet1                      = 1,
++      .enet1 = {
++              .has_phy                = 1,
++              .phy_id                 = 0,
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .leds = {
++              {
++                      .name           = "HW520:green:net",
++                      .gpio           = 32,
++                      .active_low     = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc           = "reset",
++                      .gpio           = 37,
++                      .active_low     = 1,
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_HW553 = {
+       .name                           = "HW553",
+       .expected_cpu_id                = 0x6358,
+@@ -5175,6 +5218,7 @@ static const struct board_info __initcon
+       &board_nb4_fxc_r1,
+       &board_nb4_fxc_r2,
+       &board_ct6373_1,
++      &board_HW520,
+       &board_HW553,
+       &board_HW556,
+       &board_HW556_A,
diff --git a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
new file mode 100644 (file)
index 0000000..aae5845
--- /dev/null
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -3438,6 +3438,49 @@ static struct board_info __initdata boar
+       .num_spis = ARRAY_SIZE(ct6373_spi_devices),
+ };
++static struct board_info __initdata board_HW520 = {
++      .name                           = "HW6358GW_B",
++      .expected_cpu_id                = 0x6358,
++
++      .has_uart0                      = 1,
++      .has_pci                        = 1,
++      .has_ohci0                      = 1,
++      .has_ehci0                      = 1,
++
++      .has_enet0                      = 1,
++      .enet0 = {
++              .has_phy                = 1,
++              .use_internal_phy       = 1,
++      },
++
++      .has_enet1                      = 1,
++      .enet1 = {
++              .has_phy                = 1,
++              .phy_id                 = 0,
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .leds = {
++              {
++                      .name           = "HW520:green:net",
++                      .gpio           = 32,
++                      .active_low     = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc           = "reset",
++                      .gpio           = 37,
++                      .active_low     = 1,
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_HW553 = {
+       .name                           = "HW553",
+       .expected_cpu_id                = 0x6358,
+@@ -5185,6 +5228,7 @@ static const struct board_info __initcon
+       &board_nb4_fxc_r1,
+       &board_nb4_fxc_r2,
+       &board_ct6373_1,
++      &board_HW520,
+       &board_HW553,
+       &board_HW556,
+       &board_HW556_A,