mac80211: make b43 N-PHY default for brcm47xx legacy subtarget
authorRafał Miłecki <zajec5@gmail.com>
Wed, 8 Apr 2015 05:55:28 +0000 (05:55 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Wed, 8 Apr 2015 05:55:28 +0000 (05:55 +0000)
Subtarget legacy is supposed to support all ssb SoC except for BCM4705.
There are few BCM4703 devices with 802.11n supprt (WRT160N v1.0, v1.1).
Few BCM4704 devices with 802.11n: ASUS WL-500W, Linksys WRT150N v1.0 &
v1.1, Linksys WRT300N v1.0, Netgear WNDR3300 v1, WNR834B v1 & v2.

It seems we have to enable N-PHY for legacy as well to support above.
Unfortunately it increases root.squashfs size by 48 460 B.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 45309

package/kernel/mac80211/Makefile

index 11c8bcfa1ae3be68cdeb740648749165ecd6033d..2a40bb1933010eadd364a2229f61153f6f4848a4 100644 (file)
@@ -1235,9 +1235,9 @@ config PACKAGE_B43_USE_BCMA
        config B43_FW_SQUASH_PHYTYPES
                string "PHY types to include"
                depends on B43_FW_SQUASH
-               default "G,LP" if TARGET_brcm47xx_legacy
+               default "G,N,LP" if TARGET_brcm47xx_legacy
                default "N,HT" if TARGET_brcm47xx_mips74k
-               default "G,LP,N,HT"
+               default "G,N,LP,HT"
                help
                  This is a comma seperated list of PHY types:
                    A  => A-PHY
@@ -1307,7 +1307,6 @@ config PACKAGE_B43_USE_BCMA
 
        config PACKAGE_B43_PHY_N
                bool "Enable support for N-PHYs"
-               default n if TARGET_brcm47xx_legacy
                default y
                help
                  Enable support for N-PHY. This includes support for the following devices: