lantiq: add esi
authorJohn Crispin <john@openwrt.org>
Sun, 30 Mar 2014 09:16:43 +0000 (09:16 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 30 Mar 2014 09:16:43 +0000 (09:16 +0000)
http://patchwork.openwrt.org/patch/3703/

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 40326

target/linux/lantiq/base-files/etc/init.d/esi [new file with mode: 0755]
target/linux/lantiq/xway/target.mk

diff --git a/target/linux/lantiq/base-files/etc/init.d/esi b/target/linux/lantiq/base-files/etc/init.d/esi
new file mode 100755 (executable)
index 0000000..5635b53
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2013 OpenWrt.org
+
+START=19
+start() {
+       esi $(printf '%X' $((1+0x$(tr -d : </sys/class/net/eth0/address)))) 2>/dev/null || :
+}
index 3da4638da3d3da77cfef8157ac9bc85b7da68235..1a8bbb4bc025ac037c946ad21e698c01b55d4f15 100644 (file)
@@ -5,7 +5,7 @@ FEATURES:=squashfs atm mips16
 CPU_TYPE:=34kc
 CPU_SUBTYPE:=dsp
 
-DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug atm-esi
 
 define Target/Description
        Lantiq XWAY