sipsak fixes:
authorNicolas Thill <nico@openwrt.org>
Sun, 11 Jan 2009 00:35:11 +0000 (00:35 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 11 Jan 2009 00:35:11 +0000 (00:35 +0000)
 - fix for SSP detection: gcc accepts -fstack-protector even if SSP is disabled, but will fail at linking
 - sanitize & cleanup
 - bump release number

SVN-Revision: 13969

net/sipsak/Makefile
net/sipsak/patches/001-ssp.patch [new file with mode: 0644]

index 0386b50023cbf882070d7360cf44d13a9318f585..0b297040bbb774dfe22a59cfdfa4756fe7f18d23 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sipsak
 PKG_VERSION:=0.9.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/sipsak/ \
@@ -27,11 +27,8 @@ define Package/sipsak
   URL:=http://www.sipsak.org/
 endef
                        
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-gnutls \
-       )
-endef
+CONFIGURE_ARGS += \
+       --disable-gnutls \
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
diff --git a/net/sipsak/patches/001-ssp.patch b/net/sipsak/patches/001-ssp.patch
new file mode 100644 (file)
index 0000000..1dda867
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -363,7 +363,7 @@ AC_DEFUN([SIPSAK_GCC_STACK_PROTECT_CC],[
+     AC_MSG_CHECKING([whether ${CC} accepts -fstack-protector])
+     ssp_old_cflags="$CFLAGS"
+     CFLAGS="$CFLAGS -fstack-protector"
+-    AC_TRY_COMPILE(,,, ssp_cc=no)
++    AC_TRY_LINK(,,, ssp_cc=no)
+     echo $ssp_cc
+     if test "X$ssp_cc" = "Xno"; then
+       CFLAGS="$ssp_old_cflags"
+--- a/configure
++++ b/configure
+@@ -2923,7 +2923,7 @@ main ()
+ _ACEOF
+ rm -f conftest.$ac_objext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+-  (eval $ac_compile) 2>conftest.er1
++  (eval $ac_link) 2>conftest.er1
+   ac_status=$?
+   grep -v '^ *+' conftest.er1 >conftest.err
+   rm -f conftest.er1