fix vim-full config (thanks to frogonwheels), bump release number
authorNicolas Thill <nico@openwrt.org>
Sat, 20 Sep 2008 11:35:24 +0000 (11:35 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 20 Sep 2008 11:35:24 +0000 (11:35 +0000)
SVN-Revision: 12635

utils/vim/Makefile
utils/vim/files/vimrc.full

index e388d44ce25cf936911b8cd836aad4979885fdf3..aaefc10b9439acec8cbcc84d6679d82f8fe08cce 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vim
 PKG_VERSION:=7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
index c67e4db795090f0b92535ad29a8ef0f912e6a8a4..65322f8554de10d67467ca1b7d2717462df87557 100644 (file)
@@ -1,23 +1,24 @@
-set showcmd            " Show (partial) command in status line.
-set showmatch          " Show matching brackets.
-set ignorecase         " Do case insensitive matching
-set incsearch          " Incremental search
-set autowrite          " Automatically save before commands like :next 
-and :make
-set nocompatible        " Use Vim defaults instead of 100% vi compatibility
+set showcmd  " Show (partial) command in status line.
+set showmatch  " Show matching brackets.
+set ignorecase  " Do case insensitive matching
+set incsearch  " Incremental search
+set autowrite  " Automatically save before commands like :next and :make
+set nocompatible  " Use Vim defaults instead of 100% vi compatibility
 set backspace=indent,eol,start  " more powerful backspacing
-set autoindent          " always set autoindenting on
-set linebreak         " Don't wrap words by default
-set textwidth=0         " Don't wrap lines by default
-set ruler               " show the cursor position all the time
-if has('syntax') && &term =~ "xterm"
+set autoindent  " always set autoindenting on
+set linebreak  " Don't wrap words by default
+set textwidth=0  " Don't wrap lines by default
+set ruler  " show the cursor position all the time
+if filereadable(expand("$VIMRUNTIME/syntax/synload.vim"))
+  syntax on
+endif
+if has("syntax") && &term =~ "xterm"
+  set t_Co=8
   if has("terminfo")
-    set t_Co=8
     set t_Sf=<Esc>[3%p1%dm
     set t_Sb=<Esc>[4%p1%dm
   else
-    set t_Co=8
     set t_Sf=<Esc>[3%dm
     set t_Sb=<Esc>[4%dm
   endif
-  syn on
+endif