[packages] xkeyboard-config: misc fixes:
authorNicolas Thill <nico@openwrt.org>
Sun, 1 Aug 2010 17:06:20 +0000 (17:06 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 1 Aug 2010 17:06:20 +0000 (17:06 +0000)
 * add MD5SUM
 * remove unneeded Build/Configure override
 * fix indent in Package/.../install
 * check for host intltool

SVN-Revision: 22459

Xorg/xorg/data/xkeyboard-config/Makefile

index be355b7850e23ce2a12d0ffaa6c96f3b3f661bbb..dbbc14c7e26250da1cbc21666edc59dca9ea77f0 100644 (file)
@@ -13,8 +13,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://xlibs.freedesktop.org/xkbdesc/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://xlibs.freedesktop.org/xkbdesc/
-PKG_INSTALL:=1
+PKG_MD5SUM:=d351c0109fac166edcedad32d1b0e38e
 
 
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,13 +27,13 @@ define Package/xkeyboard-config
   URL:=http://freedesktop.org/wiki/Software/XKeyboardConfig
 endef
 
   URL:=http://freedesktop.org/wiki/Software/XKeyboardConfig
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
-endef
 define Package/xkeyboard-config/install
 define Package/xkeyboard-config/install
-  $(INSTALL_DIR) $(1)/usr/share/X11/xkb
-    $(CP) -v $(PKG_INSTALL_DIR)/usr/share/X11/xkb \
-      $(1)/usr/share/X11/
+       $(INSTALL_DIR) $(1)/usr/share/X11
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/X11/xkb $(1)/usr/share/X11/
 endef
 
 endef
 
+$(eval $(call RequireCommand,intltool-update, \
+       $(PKG_NAME) requires intltool installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,xkeyboard-config))
 $(eval $(call BuildPackage,xkeyboard-config))