[package] dnsmasq:
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 5 Oct 2009 16:58:06 +0000 (16:58 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 5 Oct 2009 16:58:06 +0000 (16:58 +0000)
 - make "name" option in "host" sections optional and append it to -G if set,
   allows specifying hostnames for static leases without resorting to /etc/hosts
 - implement "domain" sections, allows defining arbitary host names and associated
   ptr records from uci
 - bump package revision

SVN-Revision: 17897

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 4b10243f5a69e1ad5d08c932123c706e96834417..dc083f4b65beeb4fe04384b388f2390a181346a9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.50
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.50
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 1aeeb94b26aea69219d157ba2ce064c5f65641b5..ba1bf721dd29c1a76dcba9bc9511a5082f01502e 100644 (file)
@@ -3,6 +3,7 @@
 
 START=60
 DNS_SERVERS=""
 
 START=60
 DNS_SERVERS=""
+DOMAIN=""
 
 dhcp_calc() {
        local ip="$1"
 
 dhcp_calc() {
        local ip="$1"
@@ -83,6 +84,8 @@ dnsmasq() {
        append_parm "$cfg" "tftp_root" "--tftp-root"
        append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
 
        append_parm "$cfg" "tftp_root" "--tftp-root"
        append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
 
+       config_get DOMAIN "$cfg" domain
+
        config_get leasefile $cfg leasefile
        [ -e "$leasefile" ] || touch "$leasefile"
        config_get_bool cachelocal "$cfg" cachelocal 1
        config_get leasefile $cfg leasefile
        [ -e "$leasefile" ] || touch "$leasefile"
        config_get_bool cachelocal "$cfg" cachelocal 1
@@ -165,7 +168,7 @@ dhcp_host_add() {
        local cfg="$1"
 
        config_get name "$cfg" name
        local cfg="$1"
 
        config_get name "$cfg" name
-       [ -n "$name" ] || return 0
+       [ -n "$name" ] && dhcp_option_add "$cfg" "$name"
 
        config_get mac "$cfg" mac
        [ -n "$mac" ] || return 0
 
        config_get mac "$cfg" mac
        [ -n "$mac" ] || return 0
@@ -173,9 +176,7 @@ dhcp_host_add() {
        config_get ip "$cfg" ip
        [ -n "$ip" ] || return 0
 
        config_get ip "$cfg" ip
        [ -n "$ip" ] || return 0
 
-       append args "--dhcp-host=$mac,$ip"
-
-       dhcp_option_add "$cfg" "$name"
+       append args "--dhcp-host=$mac,$ip${name:+,$name}"
 }
 
 dhcp_mac_add() {
 }
 
 dhcp_mac_add() {
@@ -270,6 +271,20 @@ dhcp_option_add() {
 
 }
 
 
 }
 
+dhcp_domain_add() {
+       local cfg="$1"
+
+       config_get name "$cfg" name
+       [ -n "$name" ] || return 0
+
+       config_get ip "$cfg" ip
+       [ -n "$ip" ] || return 0
+
+       local oIFS="$IFS"; IFS="."; set -- $ip; IFS="$oIFS"
+       append args "-A /$name${DOMAIN:+.$DOMAIN}/$ip"
+       append args "--ptr-record=$4.$3.$2.$1.in-addr.arpa,$name${DOMAIN:+.$DOMAIN}"
+}
+
 start() {
        include /lib/network
        scan_interfaces
 start() {
        include /lib/network
        scan_interfaces
@@ -285,6 +300,7 @@ start() {
        config_foreach dhcp_circuitid_add circuitid
        config_foreach dhcp_remoteid_add remoteid
        config_foreach dhcp_subscrid_add subscrid
        config_foreach dhcp_circuitid_add circuitid
        config_foreach dhcp_remoteid_add remoteid
        config_foreach dhcp_subscrid_add subscrid
+       config_foreach dhcp_domain_add domain
        config_foreach dhcp_add dhcp
 
        /usr/sbin/dnsmasq $args && {
        config_foreach dhcp_add dhcp
 
        /usr/sbin/dnsmasq $args && {