polarssl: patch CVE-2015-1182
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 20 Jan 2015 12:49:54 +0000 (12:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 20 Jan 2015 12:49:54 +0000 (12:49 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44060

package/libs/polarssl/Makefile
package/libs/polarssl/patches/300-CVE-2015-1182.patch [new file with mode: 0644]

index 18e0f44fe970aaa6b0cff11a4938e157aeb0e0f8..384853e29caecad599ab1ee8a7d6c5a32be4d981 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2011-2013 OpenWrt.org
+# Copyright (C) 2011-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=polarssl
 PKG_VERSION:=1.3.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
diff --git a/package/libs/polarssl/patches/300-CVE-2015-1182.patch b/package/libs/polarssl/patches/300-CVE-2015-1182.patch
new file mode 100644 (file)
index 0000000..5961d37
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/library/asn1parse.c
++++ b/library/asn1parse.c
+@@ -278,6 +278,8 @@ int asn1_get_sequence_of( unsigned char
+             if( cur->next == NULL )
+                 return( POLARSSL_ERR_ASN1_MALLOC_FAILED );
++            memset( cur->next, 0, sizeof( asn1_sequence ) );
++
+             cur = cur->next;
+         }
+     }