[packages] rsync: Add initscript for rsync daemon
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Tue, 12 Apr 2011 23:18:19 +0000 (23:18 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Tue, 12 Apr 2011 23:18:19 +0000 (23:18 +0000)
Add an initscript to the rsync package for use as a daemon, and a sample rsyncd.conf to show a simple setup.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 26630

net/rsync/Makefile
net/rsync/files/rsyncd.conf [new file with mode: 0644]
net/rsync/files/rsyncd.init [new file with mode: 0644]

index 8035f7c9d841340b603722bd3372e6dc2049c182..d6342b5afab56a2035232b87fbb851d7e34674ab 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
@@ -49,6 +49,10 @@ CONFIGURE_ARGS += \
        --disable-acl-support \
 
 define Package/rsync/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/rsyncd.init $(1)/etc/init.d/rsyncd
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
diff --git a/net/rsync/files/rsyncd.conf b/net/rsync/files/rsyncd.conf
new file mode 100644 (file)
index 0000000..896f368
--- /dev/null
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+# Minimal configuration for rsync daemon
+
+# Next line required for init script
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+uid = nobody
+gid = nogroup
+read only = yes
+
+# Simple example to configure server
+#[openwrt-etc]
+#path = /etc
+#comment = OpenWrt Configuration Files
+#exclude = /init.d
diff --git a/net/rsync/files/rsyncd.init b/net/rsync/files/rsyncd.init
new file mode 100644 (file)
index 0000000..a24a790
--- /dev/null
@@ -0,0 +1,15 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=50
+BIN=/usr/bin/rsync
+PID=/var/run/rsyncd.pid
+SSD=start-stop-daemon
+
+start() {
+       $SSD -p $PID -S -x $BIN -- --daemon 
+}
+
+stop() {
+       $SSD -p $PID -K
+}