oprofile: add a separate package for extra utilities
authorFelix Fietkau <nbd@openwrt.org>
Sun, 31 Oct 2010 13:08:55 +0000 (13:08 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 31 Oct 2010 13:08:55 +0000 (13:08 +0000)
SVN-Revision: 23734

devel/oprofile/Makefile

index 01663634cc5ddcd1cddd1498aa80876775f02de4..2961e2dfc5cdd54c30d0881a9b90e8086a2fb0eb 100644 (file)
@@ -46,6 +46,14 @@ define Package/oprofile/description
  A transparent low-overhead system-wide profiler.
 endef
 
+define Package/oprofile-utils
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=OProfile System Profiler (extra utilities)
+  URL:=http://oprofile.sourceforge.net
+  DEPENDS:=oprofile
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-kernel-support \
@@ -55,12 +63,26 @@ endef
 
 TARGET_LDFLAGS := -L$(STAGING_DIR)/usr/lib $(TARGET_LDFLAGS)
 
+define Package/oprofile-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/opannotate \
+               $(PKG_INSTALL_DIR)/usr/bin/oparchive \
+               $(PKG_INSTALL_DIR)/usr/bin/opgprof \
+               $(1)/usr/bin
+endef
+
 define Package/oprofile/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin
 
+       rm -f \
+               $(1)/usr/bin/opannotate \
+               $(1)/usr/bin/oparchive \
+               $(1)/usr/bin/opgprof
+
        $(INSTALL_DIR) $(1)/usr/lib/oprofile
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/oprofile/*.so* \
@@ -74,4 +96,5 @@ define Package/oprofile/install
 endef
 
 $(eval $(call BuildPackage,oprofile))
+$(eval $(call BuildPackage,oprofile-utils))
 $(eval $(call KernelPackage,oprofile))