added host utility <bjam> by <boost> (yet another build tool)
authorMirko Vogt <mirko@openwrt.org>
Thu, 12 Mar 2009 22:09:16 +0000 (22:09 +0000)
committerMirko Vogt <mirko@openwrt.org>
Thu, 12 Mar 2009 22:09:16 +0000 (22:09 +0000)
SVN-Revision: 14860

devel/boost-jam/Makefile [new file with mode: 0644]

diff --git a/devel/boost-jam/Makefile b/devel/boost-jam/Makefile
new file mode 100644 (file)
index 0000000..98137b3
--- /dev/null
@@ -0,0 +1,44 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 14696 2009-02-28 20:50:40Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=boost-jam
+PKG_VERSION:=3.1.17
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=@SF/boost
+
+BUILDONLY:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/boost-jam
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=Boost JAM
+  URL:=http://www.boost.org
+endef
+
+define Build/DefaultTargets
+endef
+
+define Host/Compile
+       # bjam does not provide a configure-script nor a Makefile
+       ( cd $(HOST_BUILD_DIR) ; ./build.sh gcc )
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/usr/bin
+       $(CP) $(HOST_BUILD_DIR)/bin.*/bjam $(STAGING_DIR_HOST)/usr/bin/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,boost-jam))