tsocks: avoid linking statically
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:09:42 +0000 (21:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:09:42 +0000 (21:09 +0000)
SVN-Revision: 32542

net/tsocks/patches/100-no_static.patch [new file with mode: 0644]

diff --git a/net/tsocks/patches/100-no_static.patch b/net/tsocks/patches/100-no_static.patch
new file mode 100644 (file)
index 0000000..1a9afb4
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -47,7 +47,7 @@
+       ${SHCC} ${CFLAGS} ${INCLUDES} -o ${INSPECT} ${INSPECT}.c ${COMMON}.o ${LIBS} 
+ ${SAVE}: ${SAVE}.c
+-      ${SHCC} ${CFLAGS} ${INCLUDES} -static -o ${SAVE} ${SAVE}.c
++      ${SHCC} ${CFLAGS} ${INCLUDES} -o ${SAVE} ${SAVE}.c
+ ${SHLIB}: ${OBJS} ${COMMON}.o ${PARSER}.o
+       ${SHCC} ${CFLAGS} ${INCLUDES} -nostdlib -shared -o ${SHLIB} ${OBJS} ${COMMON}.o ${PARSER}.o ${DYNLIB_FLAGS} ${SPECIALLIBS} ${LIBS}