shrink e2fsprogs package by replacing a copy with a symlink
authorFelix Fietkau <nbd@openwrt.org>
Sat, 20 Jan 2007 04:57:49 +0000 (04:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 20 Jan 2007 04:57:49 +0000 (04:57 +0000)
SVN-Revision: 6139

utils/e2fsprogs/Makefile

index 462a36e1cf3a462f4d7d04183f41d9b365bec567..e752b6627b42a0286e7af16f2a159e64388af758 100644 (file)
@@ -59,7 +59,7 @@ endef
 define Package/e2fsprogs/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/e2fsck $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
+       ln -sf mkfs.ext2 $(1)/usr/sbin/mke2fs
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkfs.ext{2,3} $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tune2fs $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/resize2fs $(1)/usr/sbin/