ramips: build sysupgrade image for the V11ST-FE board
authorGabor Juhos <juhosg@openwrt.org>
Sun, 19 Feb 2012 17:52:08 +0000 (17:52 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 19 Feb 2012 17:52:08 +0000 (17:52 +0000)
SVN-Revision: 30648

target/linux/ramips/image/Makefile

index 588dfa55fb19076997fe2557d6da0a6025145f4f..770b12e62e6cd20f0099f104d3d15ef32b95d0e8 100644 (file)
@@ -353,6 +353,11 @@ define Image/Build/Profile/RTN15
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
 endef
 
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
 endef
 
+mtdlayout_v11stfe=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1280k(kernel),2112k(rootfs),3392k@0x50000(firmware)
+define Image/Build/Profile/V11STFE
+       $(call BuildFirmware/Generic,$(1),v11st-fe,board=V11ST-FE,mtdlayout_v11stfe,1310720,2162688)
+endef
+
 mtdlayout_wlitx4ag300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
 define Image/Build/Profile/WLITX4AG300N
        $(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,mtdlayout_wlitx4ag300n,851968,2949120)
 mtdlayout_wlitx4ag300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
 define Image/Build/Profile/WLITX4AG300N
        $(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,mtdlayout_wlitx4ag300n,851968,2949120)
@@ -362,6 +367,7 @@ ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
+       $(call Image/Build/Profile/V11STFE,$(1))
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef
 endif
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef
 endif