Fixed user-space br2684ctl to be more verbose, also copy all the libatm dependencies.
authorFlorian Fainelli <florian@openwrt.org>
Tue, 7 Feb 2006 13:12:05 +0000 (13:12 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 7 Feb 2006 13:12:05 +0000 (13:12 +0000)
SVN-Revision: 3179

openwrt/package/linux-atm/Makefile
openwrt/package/linux-atm/patches/100-br2684.patch

index 93da3afcd463f3e1b9070c5fae4c83e005d0a0fe..ee3ac99118cd42cdac6cd4d517118b6f9b504b59 100644 (file)
@@ -56,7 +56,7 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_LINUX_ATM): 
        install -d -m0755 $(IDIR_LINUX_ATM)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(IDIR_LINUX_ATM)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1* $(IDIR_LINUX_ATM)/usr/lib
        $(RSTRIP) $(IDIR_LINUX_ATM)/
        $(IPKG_BUILD) $(IDIR_LINUX_ATM) $(PACKAGE_DIR)
 
index 94239ae97cef22fd8de5ed5bfe1a2083349817ec..58eab460e82e121cb1ed2dabdf6c9560f19fe530 100644 (file)
@@ -176,10 +176,9 @@ diff -Nur linux-atm-2.4.1.orig/src/include/linux/atmbr2684.h linux-atm-2.4.1/src
 +                              struct br2684_filter_set)
 +
 +#endif                                /* _LINUX_ATMBR2684_H */
-diff Nur linux-atm-2.4.1.orig/src/br2684/br2684ctl.c linux-atm-2.4.1/src/br2684/br2684ctl.c
---- linux-atm-2.4.1.orig/src/br2684/br2684ctl.c
-+++ linux-atm-2.4.1/src/br2684/br2684ctl.c
-@@ -0,0 +1,302 @@
+--- linux-atm-2.4.1/src/br2684/br2684ctl.c     1970-01-01 01:00:00.000000000 +0100
++++ linux-atm-2.4.1.new/src/br2684/br2684ctl.c 2006-02-07 14:05:14.000000000 +0100
+@@ -0,0 +1,307 @@
 +#include <stdio.h>
 +#include <stdlib.h>
 +#include <unistd.h>
@@ -270,8 +269,8 @@ diff Nur linux-atm-2.4.1.orig/src/br2684/br2684ctl.c linux-atm-2.4.1/src/br2684/
 +
 +                      if (err == 0)
 +                              syslog(LOG_INFO,
-+                                     "Interface \"%s\" created sucessfully\n",
-+                                     ni.ifname);
++                                     "Interface \"%s\" (mtu=%d, payload=%s) created sucessfully\n",
++                                     ni.ifname, ni.mtu,ni.payload ? "bridged" : "routed");
 +                      else
 +                              syslog(LOG_INFO,
 +                                     "Interface \"%s\" could not be created, reason: %s\n",
@@ -369,8 +368,13 @@ diff Nur linux-atm-2.4.1.orig/src/br2684/br2684ctl.c linux-atm-2.4.1/src/br2684/
 +
 +void usage(char *s)
 +{
-+      printf
-+          ("usage: %s [-b] [[-c number] [-e 0|1] [-p 0|1] [-t 4|6] [-a [itf.]vpi.vci]*]*\n",
++      printf("usage: %s [-b] [[-c number] [-e 0|1] [-p 0|1] [-s num] [-a                       [itf.]vpi.vci]*]*\n"
++                      " -b               = run in background (daemonize)\n"
++                      " -c <num>         = use interface nas<num>\n"
++                      " -e 0|1           = encapsulation (0=LLC, 1=VC Mux)\n"
++                      " -p 0|1           = payload type (0=routed,1=bridged)\n"
++                      " -s <num>         = set sndbuf (send buffer) size (default 8192)\n"
++                      " -a [itf.]vpi.vci = ATM interface no, VPI, VCI\n",
 +           s);
 +      exit(1);
 +}