[package] grub: fix potential build issues on redhat/fedora host systems (should...
authorNicolas Thill <nico@openwrt.org>
Mon, 4 May 2009 23:08:08 +0000 (23:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 4 May 2009 23:08:08 +0000 (23:08 +0000)
SVN-Revision: 15608

package/grub/Makefile
package/grub/patches/002-strip_note_gnu_build_id.patch [new file with mode: 0644]

index 7e6f3527ecac5210e89bc9e3470a44e47f619d65..40cc8ef4c03d9a62ac10978f5b01f6d40b2bd8fc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=grub
 PKG_VERSION:=0.97
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
diff --git a/package/grub/patches/002-strip_note_gnu_build_id.patch b/package/grub/patches/002-strip_note_gnu_build_id.patch
new file mode 100644 (file)
index 0000000..40aa74d
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/stage1/Makefile.in
++++ b/stage1/Makefile.in
+@@ -427,7 +427,7 @@ uninstall-am: uninstall-info-am uninstal
+       uninstall-nodist_pkglibDATA
+ .exec:
+-      $(OBJCOPY) -O binary $< $@
++      $(OBJCOPY) -O binary -R .comment -R .note -R .note.gnu.build-id $< $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
+--- a/stage2/Makefile.in
++++ b/stage2/Makefile.in
+@@ -3244,7 +3244,7 @@ pxegrub: pxeloader diskless
+       -rm -f $@
+       cat $^ > $@
+ .exec:
+-      $(OBJCOPY) -O binary $< $@
++      $(OBJCOPY) -O binary -R .comment -R .note -R .note.gnu.build-id $< $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: