packages/dovecot: use new service functions, move user/group creation from postinst...
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:25:15 +0000 (23:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:25:15 +0000 (23:25 +0000)
SVN-Revision: 28903

mail/dovecot/Makefile
mail/dovecot/files/dovecot.init

index 614cc18e412fd9627b69a11d36210235fe7ca0a2..850a72e0874da2a0033d036b9b79ef3c7cab6fe9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
 PKG_VERSION:=1.2.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
@@ -74,41 +74,4 @@ define Package/dovecot/conffiles
 /etc/dovecot.conf
 endef
 
-define Package/dovecot/postinst
-#!/bin/sh
-
-id=59
-name=dovecot
-home=/var/run/dovecot
-shell=/bin/false
-
-# do not change below
-# check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp -p /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp -p /rom/etc/passwd /etc/passwd
-                fi
-        fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:$${home}:$${shell}" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-endef
-
-
 $(eval $(call BuildPackage,dovecot))
index 00f0edbc3acb7217254ef6c2dce2ed4738543e6e..7539fb614d4e9d0519ccd6017412ca2f46c181b9 100644 (file)
@@ -1,20 +1,23 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=99
 
-RUN_D=/var/run/dovecot
-PID_F=$RUN_D/master.pid
+SERVICE_PID_FILE=/var/run/dovecot/master.pid
 
 start() {
-       mkdir -p $RUN_D
-       dovecot
+       user_exists dovecot 59 || user_add dovecot 59
+       group_exists dovecot 59 || group_add dovecot 59
+       mkdir -p -m 0755 /var/lib/dovecot
+       mkdir -p -m 0755 /var/run/dovecot
+       chmod 0750 /var/lib/dovecot
+       service_start /usr/sbin/dovecot
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/dovecot
 }
 
 reload() {
-       [ -f $PID_F ] && kill -HUP $(cat $PID_F)
+       service_reload /usr/sbin/dovecot
 }