[package] iwinfo: fix wl backend, unsigned -> signed for mcs idx, revision bump after...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 23 Feb 2012 18:20:51 +0000 (18:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 23 Feb 2012 18:20:51 +0000 (18:20 +0000)
SVN-Revision: 30693

package/iwinfo/Makefile
package/iwinfo/src/include/iwinfo.h
package/iwinfo/src/iwinfo_wl.c

index 079fe682fe924147ebf7f575f424eb58f5405414..f74fe2f1f9bcd88806c542f5e17a688380ee50bc 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=30
+PKG_RELEASE:=31
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 3c8b4188312fce94a7abd55952f1e75402614b76..9e78bab70efc52f9e2aaf8b72514ed0590dbe3ad 100644 (file)
@@ -62,7 +62,7 @@ extern const char *IWINFO_OPMODE_NAMES[];
 
 struct iwinfo_rate_entry {
        uint16_t rate;
-       uint8_t mcs;
+       int8_t mcs;
        uint8_t is_40mhz:1;
        uint8_t is_short_gi:1;
 };
index b7e5d19786f89f8a81e9b2f59a1d79f7d6c4602d..3d15fc9ca7518b76c1ee6b3ede2d5536c4a212b2 100644 (file)
@@ -401,8 +401,8 @@ static void wl_get_assoclist_cb(const char *ifname,
                e->tx_rate.rate = sta.tx_rate;
 
                /* ToDo: 11n */
-               e.rx_rate.mcs = -1;
-               e.tx_rate.mcs = -1;
+               e->rx_rate.mcs = -1;
+               e->tx_rate.mcs = -1;
        }
 }