net/xtables-addons: update to version 1.31. this series of updates closes #8369
authorAlexandros C. Couloumbis <alex@ozo.com>
Fri, 10 Dec 2010 16:24:35 +0000 (16:24 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Fri, 10 Dec 2010 16:24:35 +0000 (16:24 +0000)
SVN-Revision: 24433

net/xtables-addons/Makefile
net/xtables-addons/patches/001-no_depmod.patch
net/xtables-addons/patches/002-configure_fix.patch [new file with mode: 0644]

index 53c4106e56098b4d967655e93694bab69ff6ad2a..f329be748833b38c7f584334b8de99e7502801ca 100644 (file)
@@ -9,16 +9,19 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=1.29
+PKG_VERSION:=1.31
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=acfc41b5065706143e4a0570de458781
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=97ac895a67df67c28def98763023d51b
 PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=aclocal.m4 autoconf/ltmain.sh
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xtables-addons
@@ -103,7 +106,7 @@ $(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,xt_CHAOS,47,+kmod-ipt-compat-xt
 $(eval $(call BuildTemplate,condition,Condition,xt_condition,xt_condition,46,))
 $(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,xt_DELUDE,46,+kmod-ipt-compat-xtables))
 $(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
-$(eval $(call BuildTemplate,tee,TEE,xt_TEE,xt_TEE,46,+kmod-ipt-compat-xtables))
+#$(eval $(call BuildTemplate,tee,TEE,xt_TEE,xt_TEE,46,+kmod-ipt-compat-xtables))
 $(eval $(call BuildTemplate,ipp2p,IPP2P,xt_ipp2p,xt_ipp2p,46,))
 $(eval $(call BuildTemplate,rawpost,RAWPOST,,iptable_rawpost,46,+kmod-ipt-compat-xtables))
 $(eval $(call BuildTemplate,rawnat,RAWNAT,xt_RAWDNAT xt_RAWSNAT,xt_RAWNAT,46,+kmod-ipt-compat-xtables))
index 611af349998e84bf1c3867c027bed17b83503faa..08ba7b4d85852011351c3048cd2768916f0ee455 100644 (file)
@@ -2,8 +2,8 @@
  Makefile.in |    3 +--
  1 file changed, 1 insertion(+), 2 deletions(-)
 
---- xtables-addons-1.29.orig/Makefile.in
-+++ xtables-addons-1.29/Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
 @@ -754,8 +754,7 @@ install-dvi: install-dvi-recursive
  install-dvi-am:
  
diff --git a/net/xtables-addons/patches/002-configure_fix.patch b/net/xtables-addons/patches/002-configure_fix.patch
new file mode 100644 (file)
index 0000000..fb4de66
--- /dev/null
@@ -0,0 +1,17 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -56,14 +56,6 @@ krel="${krel#*.}";
+ kminor="${krel%%.*}";
+ krel="${krel#*.}";
+ kmicro="${krel%%.*}";
+-if test "$kmicro" = "$krel"; then
+-      kmicro="$(($kmicro+0))"; # Get rid of non numbers ("2.6.36+" -> "2.6.36")
+-      kstable=0;
+-else
+-      kmicro="$(($kmicro+0))";
+-      kstable="${krel#*.}";
+-      kstable="$(($kstable+0))";
+-fi;
+ if test -z "$kmajor" -o -z "$kminor" -o -z "$kmicro"; then
+       echo "WARNING: Version detection did not succeed. Continue at own luck.";
+ else