Upgrade fuse to 2.6.5 (#1955)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 23 Jun 2007 15:54:36 +0000 (15:54 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 23 Jun 2007 15:54:36 +0000 (15:54 +0000)
SVN-Revision: 7716

package/fuse/Makefile
package/fuse/patches/100-cross_compile.patch
package/fuse/patches/102-no_depmod.patch
package/fuse/patches/112-no_break_on_mknod.patch
package/fuse/patches/200-disable_compat.patch
package/fuse/patches/210-posix_test_lock.patch
package/fuse/patches/220-kmem_cache.patch
package/fuse/patches/230-kobj.patch

index 792f5e67e0f1b8e4faa445942fc22652463b7b60..afdaa774c81534227821d5597a023168af6f8a31 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=fuse
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=fuse
-PKG_VERSION:=2.6.3
+PKG_VERSION:=2.6.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=3f4f5d07d12dedc0a3fd23472171fe94
+PKG_MD5SUM:=66bd30503df55a87b9868835ca5a45bc
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
index ffb8265537be1629340e40591dabc5f1043c7df7..2ce83c46f671114b5b709cc9cf9c6a4766edc91c 100644 (file)
@@ -1,7 +1,7 @@
-Index: fuse-2.6.3/kernel/configure
+Index: fuse-2.6.5/kernel/configure
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/kernel/configure   2007-06-04 13:22:29.716337712 +0200
-+++ fuse-2.6.3/kernel/configure        2007-06-04 13:22:29.783327528 +0200
+--- fuse-2.6.5.orig/kernel/configure   2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/kernel/configure        2007-06-23 13:03:50.000000000 +0200
 @@ -1851,7 +1851,9 @@
  
        { echo "$as_me:$LINENO: checking kernel source version" >&5
 @@ -1851,7 +1851,9 @@
  
        { echo "$as_me:$LINENO: checking kernel source version" >&5
index a6b9732517cb262d7c3c6115a4a6e6d9866f746d..899d3077d433631b1ded81f849153c04087486d7 100644 (file)
@@ -1,7 +1,7 @@
-Index: fuse-2.6.3/kernel/Makefile.in
+Index: fuse-2.6.5/kernel/Makefile.in
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/kernel/Makefile.in 2007-06-04 13:22:29.695340904 +0200
-+++ fuse-2.6.3/kernel/Makefile.in      2007-06-04 13:22:29.975298344 +0200
+--- fuse-2.6.5.orig/kernel/Makefile.in 2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/kernel/Makefile.in      2007-06-23 13:03:50.000000000 +0200
 @@ -25,11 +25,9 @@
  install-y: all
        $(mkdir_p) $(DESTDIR)$(fusemoduledir)
 @@ -25,11 +25,9 @@
  install-y: all
        $(mkdir_p) $(DESTDIR)$(fusemoduledir)
index 38c75c29d4e4f3ad80fcbd07c1e8dbade36006c8..93e32422547324df9ae7f39830c0d115092b3c24 100644 (file)
@@ -1,7 +1,7 @@
-Index: fuse-2.6.3/util/Makefile.in
+Index: fuse-2.6.5/util/Makefile.in
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/util/Makefile.in   2007-06-04 13:22:29.674344096 +0200
-+++ fuse-2.6.3/util/Makefile.in        2007-06-04 13:22:30.163269768 +0200
+--- fuse-2.6.5.orig/util/Makefile.in   2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/util/Makefile.in        2007-06-23 13:03:50.000000000 +0200
 @@ -489,7 +489,7 @@
  install-exec-hook:
        -chown root $(DESTDIR)$(bindir)/fusermount
 @@ -489,7 +489,7 @@
  install-exec-hook:
        -chown root $(DESTDIR)$(bindir)/fusermount
index 93c0dfc10485e196e55abf17a9f2731c3c9446e2..52c0e2e2ae592748679a86bb0b6099b11591ba70 100644 (file)
@@ -1,7 +1,7 @@
-Index: fuse-2.6.3/include/fuse_common_compat.h
+Index: fuse-2.6.5/include/fuse_common_compat.h
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/include/fuse_common_compat.h       2007-06-04 13:22:29.628351088 +0200
-+++ fuse-2.6.3/include/fuse_common_compat.h    2007-06-04 13:22:30.344242256 +0200
+--- fuse-2.6.5.orig/include/fuse_common_compat.h       2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/include/fuse_common_compat.h    2007-06-23 13:03:51.000000000 +0200
 @@ -17,6 +17,7 @@
      unsigned int keep_cache : 1;
  };
 @@ -17,6 +17,7 @@
      unsigned int keep_cache : 1;
  };
@@ -16,10 +16,10 @@ Index: fuse-2.6.3/include/fuse_common_compat.h
  void fuse_unmount_compat22(const char *mountpoint);
 -
 +#endif
  void fuse_unmount_compat22(const char *mountpoint);
 -
 +#endif
-Index: fuse-2.6.3/lib/fuse.c
+Index: fuse-2.6.5/lib/fuse.c
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/lib/fuse.c 2007-06-04 13:22:29.634350176 +0200
-+++ fuse-2.6.3/lib/fuse.c      2007-06-04 13:22:30.345242104 +0200
+--- fuse-2.6.5.orig/lib/fuse.c 2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/lib/fuse.c      2007-06-23 13:03:51.000000000 +0200
 @@ -128,6 +128,7 @@
  static pthread_mutex_t fuse_context_lock = PTHREAD_MUTEX_INITIALIZER;
  static int fuse_context_ref;
 @@ -128,6 +128,7 @@
  static pthread_mutex_t fuse_context_lock = PTHREAD_MUTEX_INITIALIZER;
  static int fuse_context_ref;
@@ -132,10 +132,10 @@ Index: fuse-2.6.3/lib/fuse.c
  __asm__(".symver fuse_new_compat25,fuse_new@FUSE_2.5");
 +
 +#endif
  __asm__(".symver fuse_new_compat25,fuse_new@FUSE_2.5");
 +
 +#endif
-Index: fuse-2.6.3/lib/fuse_lowlevel.c
+Index: fuse-2.6.5/lib/fuse_lowlevel.c
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/lib/fuse_lowlevel.c        2007-06-04 13:22:29.639349416 +0200
-+++ fuse-2.6.3/lib/fuse_lowlevel.c     2007-06-04 13:22:30.346241952 +0200
+--- fuse-2.6.5.orig/lib/fuse_lowlevel.c        2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/lib/fuse_lowlevel.c     2007-06-23 13:03:51.000000000 +0200
 @@ -1297,6 +1297,7 @@
  }
  
 @@ -1297,6 +1297,7 @@
  }
  
@@ -149,10 +149,10 @@ Index: fuse-2.6.3/lib/fuse_lowlevel.c
  
  __asm__(".symver fuse_lowlevel_new_compat25,fuse_lowlevel_new@FUSE_2.5");
 +#endif
  
  __asm__(".symver fuse_lowlevel_new_compat25,fuse_lowlevel_new@FUSE_2.5");
 +#endif
-Index: fuse-2.6.3/lib/helper.c
+Index: fuse-2.6.5/lib/helper.c
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/lib/helper.c       2007-06-04 13:22:29.645348504 +0200
-+++ fuse-2.6.3/lib/helper.c    2007-06-04 13:22:30.346241952 +0200
+--- fuse-2.6.5.orig/lib/helper.c       2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/lib/helper.c    2007-06-23 13:03:51.000000000 +0200
 @@ -195,7 +195,7 @@
                                             struct fuse_args *args)
  {
 @@ -195,7 +195,7 @@
                                             struct fuse_args *args)
  {
@@ -175,10 +175,10 @@ Index: fuse-2.6.3/lib/helper.c
  __asm__(".symver fuse_main_real_compat25,fuse_main_real@FUSE_2.5");
  __asm__(".symver fuse_mount_compat25,fuse_mount@FUSE_2.5");
 +#endif
  __asm__(".symver fuse_main_real_compat25,fuse_main_real@FUSE_2.5");
  __asm__(".symver fuse_mount_compat25,fuse_mount@FUSE_2.5");
 +#endif
-Index: fuse-2.6.3/lib/mount.c
+Index: fuse-2.6.5/lib/mount.c
 ===================================================================
 ===================================================================
---- fuse-2.6.3.orig/lib/mount.c        2007-06-04 13:22:29.652347440 +0200
-+++ fuse-2.6.3/lib/mount.c     2007-06-04 13:22:30.346241952 +0200
+--- fuse-2.6.5.orig/lib/mount.c        2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/lib/mount.c     2007-06-23 13:03:51.000000000 +0200
 @@ -219,11 +219,16 @@
      waitpid(pid, NULL, 0);
  }
 @@ -219,11 +219,16 @@
      waitpid(pid, NULL, 0);
  }
index d2e2f784c63d2da50c86cf1f44a0cd2d5d31640b..d2c746af71f2dc3ba669fc7e6f26ad45fb0527a3 100644 (file)
@@ -1,6 +1,8 @@
---- fuse.old/kernel/file.c     2007-01-28 21:25:02.000000000 +0000
-+++ fuse.dev/kernel/file.c     2007-05-29 00:10:29.000000000 +0100
-@@ -781,6 +785,10 @@
+Index: fuse-2.6.5/kernel/file.c
+===================================================================
+--- fuse-2.6.5.orig/kernel/file.c      2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/kernel/file.c   2007-06-23 13:03:51.000000000 +0200
+@@ -781,6 +781,10 @@
  
        if (cmd == F_GETLK) {
                if (fc->no_lock) {
  
        if (cmd == F_GETLK) {
                if (fc->no_lock) {
@@ -11,7 +13,7 @@
  #ifdef KERNEL_2_6_17_PLUS
                        if (!posix_test_lock(file, fl, fl))
                                fl->fl_type = F_UNLCK;
  #ifdef KERNEL_2_6_17_PLUS
                        if (!posix_test_lock(file, fl, fl))
                                fl->fl_type = F_UNLCK;
-@@ -791,6 +799,7 @@
+@@ -791,6 +795,7 @@
                        else
                                *fl = *cfl;
  #endif
                        else
                                *fl = *cfl;
  #endif
index 7fb439656d2129f9d94dacba177f73bd3d9fc6c3..79960b74f9afec1bed2adbb6c6df068b30b67811 100644 (file)
@@ -1,5 +1,7 @@
---- fuse.old/kernel/dev.c      2007-01-28 21:26:41.000000000 +0000
-+++ fuse.dev/kernel/dev.c      2007-05-29 00:28:47.000000000 +0100
+Index: fuse-2.6.5/kernel/dev.c
+===================================================================
+--- fuse-2.6.5.orig/kernel/dev.c       2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/kernel/dev.c    2007-06-23 13:03:51.000000000 +0200
 @@ -21,7 +21,11 @@
  MODULE_ALIAS_MISCDEV(FUSE_MINOR);
  #endif
 @@ -21,7 +21,11 @@
  MODULE_ALIAS_MISCDEV(FUSE_MINOR);
  #endif
@@ -12,7 +14,7 @@
  
  static struct fuse_conn *fuse_get_conn(struct file *file)
  {
  
  static struct fuse_conn *fuse_get_conn(struct file *file)
  {
-@@ -1093,9 +1093,13 @@
+@@ -1093,9 +1097,13 @@
  int __init fuse_dev_init(void)
  {
        int err = -ENOMEM;
  int __init fuse_dev_init(void)
  {
        int err = -ENOMEM;
        if (!fuse_req_cachep)
                goto out;
  
        if (!fuse_req_cachep)
                goto out;
  
---- fuse.old/kernel/inode.c    2007-02-04 13:34:51.000000000 +0000
-+++ fuse.dev/kernel/inode.c    2007-05-29 00:26:12.000000000 +0100
+Index: fuse-2.6.5/kernel/inode.c
+===================================================================
+--- fuse-2.6.5.orig/kernel/inode.c     2007-06-23 13:03:50.000000000 +0200
++++ fuse-2.6.5/kernel/inode.c  2007-06-23 13:03:51.000000000 +0200
 @@ -24,7 +24,7 @@
  MODULE_LICENSE("GPL");
  #endif
 @@ -24,7 +24,7 @@
  MODULE_LICENSE("GPL");
  #endif
index 684402f475eeb282c6d917cece3a55ba1e68414c..ecbdb5a6f7ae0ee0fab17d1c98ffdca36e61c5b6 100644 (file)
@@ -1,5 +1,7 @@
---- fuse.old/kernel/inode.c    2007-05-29 07:31:43.000000000 +0100
-+++ fuse.dev/kernel/inode.c    2007-05-29 07:29:42.000000000 +0100
+Index: fuse-2.6.5/kernel/inode.c
+===================================================================
+--- fuse-2.6.5.orig/kernel/inode.c     2007-06-23 13:03:51.000000000 +0200
++++ fuse-2.6.5/kernel/inode.c  2007-06-23 13:03:51.000000000 +0200
 @@ -858,12 +858,20 @@
        if (err)
                return err;
 @@ -858,12 +858,20 @@
        if (err)
                return err;
@@ -7,7 +9,7 @@
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
 +      kobj_set_kset_s(&fuse_subsys, fs_subsys);
 +#else
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
 +      kobj_set_kset_s(&fuse_subsys, fs_subsys);
 +#else
-       kset_set_kset_s(&fuse_subsys, fs_subsys);
+       kset_set_kset_s(&fuse_subsys, fs_subsys);
 +#endif
        err = subsystem_register(&fuse_subsys);
        if (err)
 +#endif
        err = subsystem_register(&fuse_subsys);
        if (err)
@@ -16,7 +18,7 @@
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
 +      kobj_set_kset_s(&connections_subsys, fuse_subsys);
 +#else
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
 +      kobj_set_kset_s(&connections_subsys, fuse_subsys);
 +#else
-       kset_set_kset_s(&connections_subsys, fuse_subsys);
+       kset_set_kset_s(&connections_subsys, fuse_subsys);
 +#endif
        err = subsystem_register(&connections_subsys);
        if (err)
 +#endif
        err = subsystem_register(&connections_subsys);
        if (err)