package/kernel: Fix AddDepends/SetDepends calls with make 3.82
authorJonas Gorski <jogo@openwrt.org>
Sun, 14 Aug 2011 23:36:42 +0000 (23:36 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 14 Aug 2011 23:36:42 +0000 (23:36 +0000)
The module definitions depend on 001-depends.mk being the first included,
but make 3.82 does not sort the results of wildcards anymore, so do an
explicit sort of the includes.

Found by Philip Prindeville, thanks!

SVN-Revision: 27982

package/kernel/Makefile

index d3823547aa3acac5eefd9b43641b047ca1d9cd77..13a305d7a1e99d687fec7ebfcac115a72ec20b1a 100644 (file)
@@ -45,5 +45,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
 -include $(TOPDIR)/target/linux/*/modules.mk
 -include $(TOPDIR)/target/linux/*/modules.mk