adds patch package
authorJohn Crispin <john@openwrt.org>
Wed, 11 Jun 2008 08:14:28 +0000 (08:14 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 11 Jun 2008 08:14:28 +0000 (08:14 +0000)
SVN-Revision: 11430

devel/build-essential/Makefile
devel/patch/Makefile [new file with mode: 0644]
devel/patch/patches/100-install.patch [new file with mode: 0644]

index 50eb5c62c9e55eb4d8de41cd7d302d9efbe74487..48090a3a2d71834a9ce6e5b569247bff93d9b9ea 100644 (file)
@@ -18,7 +18,7 @@ define Package/build-essential
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Build essentials 
-  DEPENDS=+gcc +make +binutils @BUILD_DEVELOPER_SYSTEM
+  DEPENDS=+gcc +make +binutils +patch @BUILD_DEVELOPER_SYSTEM
 endef
 
 define Build/Compile
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
new file mode 100644 (file)
index 0000000..19a68ca
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch
+PKG_VERSION:=2.5.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=ee5ae84d115f051d87fcaaef3b4ae782
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/patch/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/patch
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=patch
+  URL:=http://www.gnu.org/
+endef
+
+define Package/patch/description
+  The Patch package contains a program for modifying or creating files by applying a "patch" file typically created by the diff program.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default)
+endef
+
+define Build/Compile
+       $(MAKE_VARS) $(MAKE) $(MAKE_ARGS) DESTDIR=$(PKG_INSTALL_DIR) exec_prefix=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install 
+endef
+
+define Package/patch/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/patch $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,patch))
diff --git a/devel/patch/patches/100-install.patch b/devel/patch/patches/100-install.patch
new file mode 100644 (file)
index 0000000..8d34ba6
--- /dev/null
@@ -0,0 +1,18 @@
+diff -urN patch-2.5.4.orig/Makefile.in patch-2.5.4/Makefile.in
+--- patch-2.5.4.orig/Makefile.in       2008-06-11 10:08:08.000000000 +0200
++++ patch-2.5.4/Makefile.in    2008-06-11 10:08:26.000000000 +0200
+@@ -42,12 +42,12 @@
+ VERSION = @VERSION@
+ prefix = @prefix@
+-exec_prefix = @exec_prefix@
++exec_prefix += @exec_prefix@
+ bindir = $(exec_prefix)/bin
+ # Where to put the manual pages.
+-mandir = @mandir@
++mandir = $(exec_prefix)/@mandir@
+ man1dir = $(mandir)/man1
+ # Extension (including `.') for the manual page filenames.
+ man1ext = .1