[include] uclibc++.mk: override the cc binary instead of the wrapper command when...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 15 Jun 2012 12:57:29 +0000 (12:57 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 15 Jun 2012 12:57:29 +0000 (12:57 +0000)
SVN-Revision: 32383

include/uclibc++.mk

index 817484377fcee9c0f55f5238e57a4e62bc791848..084ba6aab16887856a0306592b3923e1baa0e0db 100644 (file)
@@ -8,5 +8,9 @@ PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
 CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
 CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
+ ifneq ($(CONFIG_CCACHE),)
+  TARGET_CXX_NOCACHE="g++-uc"
+ else
   TARGET_CXX="g++-uc"
   TARGET_CXX="g++-uc"
+ endif
 endif
 endif