Port cutter to -ng
authorFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 13:37:53 +0000 (13:37 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 13:37:53 +0000 (13:37 +0000)
SVN-Revision: 4367

net/cutter/Makefile [new file with mode: 0755]

diff --git a/net/cutter/Makefile b/net/cutter/Makefile
new file mode 100755 (executable)
index 0000000..f1917f3
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cutter
+PKG_VERSION:=1.03
+PKG_RELEASE:=1
+PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
+
+PKG_SOURCE_URL:=http://www.lowth.com/cutter/software/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/cutter
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=allows an user to abort TCP/IP connections
+  DESCRIPTION:="Cutter" is an open source program that allows Linux firewall\\\
+       administrators to abort TCP/IP connections routed over the\\\
+       firewall or router on which it is run.\\\
+  URL:=http://www.lowth.com/cutter/
+endef
+       
+define Build/Compile
+       $(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
+       install -d -m0755 $(PKG_INSTALL_DIR)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
+endef
+       
+define Package/cutter/install
+       mkdir -p $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+$(eval $(call BuildPackage,cutter))