ar71xx/image: add options argument to mktplinkfw step
authorJohn Crispin <john@openwrt.org>
Sun, 11 Oct 2015 16:23:44 +0000 (16:23 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 11 Oct 2015 16:23:44 +0000 (16:23 +0000)
Allow to pass extra arguments to mktplinkfw step. Some board requires
an extra argument to create a valid image.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 47174

target/linux/ar71xx/image/Makefile

index c90891716c1ed678cd70d2274885796c7f37f802..2dd7798f2173993e8134303cd3eafd9d3ab29e93 100644 (file)
@@ -38,13 +38,16 @@ define Build/netgear-uImage
 endef
 
 # combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
 # -a align the rootfs start on an <align> bytes boundary
 # -j add jffs2 end-of-filesystem markers
 # -s strip padding from end of the image
 # -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
 define Build/mktplinkfw
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $2 \
                -k $(word 1,$^) \
                -r $@ \
                -o $@.new \
@@ -64,10 +67,12 @@ define Build/mktplinkfw-chn-v2
                $(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
 endef
 
+# mktplinkfw-initramfs <optional extra arguments to mktplinkfw binary>
+#
 # -c combined image
 define Build/mktplinkfw-initramfs
        $(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $2 \
                -k $@ \
                -o $@.new \
                -s -S \