uboot-envtools: update to 2015.10
authorLuka Perkov <luka@openwrt.org>
Sat, 31 Oct 2015 19:46:56 +0000 (19:46 +0000)
committerLuka Perkov <luka@openwrt.org>
Sat, 31 Oct 2015 19:46:56 +0000 (19:46 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 47328

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/patches/100-fw_env_gnu_source.patch [deleted file]
package/boot/uboot-envtools/patches/200-fw_env_no_aes.patch
package/boot/uboot-envtools/patches/300-support-env-in-ubivol-chardev.patch

index c016ac05e12a369d838a433419928de5653d8386..54db0dd6c352a0f9bcded1847bb7c1a0b7e13dfd 100644 (file)
@@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
-PKG_VERSION:=2014.10
-PKG_RELEASE:=2
+PKG_VERSION:=2015.10
+PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
+PKG_MD5SUM:=7c203b0fc3390a122d8e8b75f147eac5
 
 PKG_BUILD_DEPENDS:=+fstools
 
@@ -46,6 +46,8 @@ endef
 define Build/Configure
        touch $(PKG_BUILD_DIR)/include/config.mk
        touch $(PKG_BUILD_DIR)/include/config.h
+       mkdir $(PKG_BUILD_DIR)/include/generated
+       touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
 endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
diff --git a/package/boot/uboot-envtools/patches/100-fw_env_gnu_source.patch b/package/boot/uboot-envtools/patches/100-fw_env_gnu_source.patch
deleted file mode 100644 (file)
index eeed1d6..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tools/env/fw_env.c
-+++ b/tools/env/fw_env.c
-@@ -8,6 +8,7 @@
-  * SPDX-License-Identifier:   GPL-2.0+
-  */
-+#define _GNU_SOURCE
- #include <errno.h>
- #include <env_flags.h>
- #include <fcntl.h>
index 05fd3c7c4f1fb29a6e53dde2f4414b6d71fbb2ab..9c8681ff4805879f4c56b47ae58b32907ab9f648 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/env/fw_env.c
 +++ b/tools/env/fw_env.c
-@@ -245,7 +245,7 @@ int fw_printenv (int argc, char *argv[])
+@@ -246,7 +246,7 @@ int fw_printenv (int argc, char *argv[])
        int i, n_flag;
        int rc = 0;
  
@@ -9,7 +9,7 @@
                if (argc < 3) {
                        fprintf(stderr,
                                "## Error: '-a' option requires AES key\n");
-@@ -324,7 +324,7 @@ int fw_printenv (int argc, char *argv[])
+@@ -325,7 +325,7 @@ int fw_printenv (int argc, char *argv[])
  int fw_env_close(void)
  {
        int ret;
@@ -18,7 +18,7 @@
                ret = env_aes_cbc_crypt(environment.data, 1);
                if (ret) {
                        fprintf(stderr,
-@@ -1222,7 +1222,7 @@ int fw_env_open(void)
+@@ -1223,7 +1223,7 @@ int fw_env_open(void)
  
        crc0 = crc32 (0, (uint8_t *) environment.data, ENV_SIZE);
  
@@ -27,7 +27,7 @@
                ret = env_aes_cbc_crypt(environment.data, 0);
                if (ret)
                        return ret;
-@@ -1279,7 +1279,7 @@ int fw_env_open(void)
+@@ -1280,7 +1280,7 @@ int fw_env_open(void)
  
                crc1 = crc32 (0, (uint8_t *) redundant->data, ENV_SIZE);
  
index b778e8a1bac29b4ecdfb2a91a99358200729f557..75d3804ed45e4b3d91d273a08b173d537362a0db 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
 --- a/tools/env/fw_env.c
 +++ b/tools/env/fw_env.c
-@@ -30,6 +30,9 @@
+@@ -31,6 +31,9 @@
  # include <mtd/mtd-user.h>
  #endif
  
@@ -37,7 +37,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  #include "fw_env.h"
  
  #include <aes.h>
-@@ -810,6 +813,11 @@ static int flash_write_buf (int dev, int
+@@ -811,6 +814,11 @@ static int flash_write_buf (int dev, int
        off_t top_of_range;     /* end of the last block we may use */
        loff_t blockstart;      /* running start of the current block -
                                   MEMGETBADBLOCK needs 64 bits */
@@ -49,7 +49,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        int rc;
  
        /*
-@@ -915,7 +923,30 @@ static int flash_write_buf (int dev, int
+@@ -916,7 +924,30 @@ static int flash_write_buf (int dev, int
                        continue;
                }
  
@@ -81,7 +81,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                        erase.start = blockstart;
                        ioctl(fd, MEMUNLOCK, &erase);
                        /* These do not need an explicit erase cycle */
-@@ -932,7 +963,8 @@ static int flash_write_buf (int dev, int
+@@ -933,7 +964,8 @@ static int flash_write_buf (int dev, int
                        fprintf (stderr,
                                 "Seek error on %s: %s\n",
                                 DEVNAME (dev), strerror (errno));
@@ -91,7 +91,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                }
  
  #ifdef DEBUG
-@@ -942,10 +974,11 @@ static int flash_write_buf (int dev, int
+@@ -943,10 +975,11 @@ static int flash_write_buf (int dev, int
                if (write (fd, data + processed, erasesize) != erasesize) {
                        fprintf (stderr, "Write error on %s: %s\n",
                                 DEVNAME (dev), strerror (errno));
@@ -105,7 +105,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                        ioctl(fd, MEMLOCK, &erase);
  
                processed  += erasesize;
-@@ -956,6 +989,11 @@ static int flash_write_buf (int dev, int
+@@ -957,6 +990,11 @@ static int flash_write_buf (int dev, int
        if (write_total > count)
                free (data);
  
@@ -117,7 +117,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        return processed;
  }
  
-@@ -1067,12 +1105,8 @@ static int flash_read (int fd)
+@@ -1068,12 +1106,8 @@ static int flash_read (int fd)
  
        if (S_ISCHR(st.st_mode)) {
                rc = ioctl(fd, MEMGETINFO, &mtdinfo);
@@ -132,7 +132,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                    mtdinfo.type != MTD_NANDFLASH &&
                    mtdinfo.type != MTD_DATAFLASH &&
                    mtdinfo.type != MTD_UBIVOLUME) {
-@@ -1080,6 +1114,28 @@ static int flash_read (int fd)
+@@ -1081,6 +1115,28 @@ static int flash_read (int fd)
                                 mtdinfo.type, DEVNAME(dev_current));
                        return -1;
                }