fix rebuild of pwlib and openh323 after root_clean.
authorNicolas Thill <nico@openwrt.org>
Wed, 17 May 2006 01:07:20 +0000 (01:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 17 May 2006 01:07:20 +0000 (01:07 +0000)
SVN-Revision: 3791

openwrt/package/openh323/Makefile
openwrt/package/pwlib/Makefile

index a17ac0099976d05143a9e4f9342ad0bfd86d5110..f85e623b6a7550e22f7b520716bfad29ecc08d70 100644 (file)
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --enable-audio \
                        --disable-video \
        );
+       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        touch $@
 
 
@@ -58,11 +59,8 @@ $(PKG_BUILD_DIR)/.built:
                optnoshared
        touch $@
 
-install-link:
-       ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
 uninstall-link:
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
 
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
 clean-targets: uninstall-link
index 66e806dc17ad3ca3a705db981875b8620c192e36..68857ff2795af3006504d6798346861c8cb93171 100644 (file)
@@ -88,6 +88,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-wavfile \
                        --disable-xmlrpc \
        );
+       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
@@ -96,11 +97,8 @@ $(PKG_BUILD_DIR)/.built:
                optnoshared
        touch $@
 
-install-link:
-       ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
 uninstall-link:
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
 
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
 clean-targets: uninstall-link