Port motion to -ng
authorFlorian Fainelli <florian@openwrt.org>
Sat, 5 Aug 2006 16:13:13 +0000 (16:13 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 5 Aug 2006 16:13:13 +0000 (16:13 +0000)
SVN-Revision: 4468

multimedia/motion/Makefile [new file with mode: 0644]
multimedia/motion/patches/01-ffmpeg.patch [new file with mode: 0644]
multimedia/motion/patches/02-honor_cppflags.patch [new file with mode: 0644]

diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
new file mode 100644 (file)
index 0000000..a29d90a
--- /dev/null
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=motion
+PKG_VERSION:=3.2.6
+PKG_RELEASE:=1
+PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
+
+PKG_SOURCE_URL:=@SF/motion
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/motion
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  DEPENDS:=+libjpeg
+  TITLE:=webcam motion sensing and logging
+  DESCRIPTION:=Motion is a software motion detector
+  URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,--without-ffmpeg \
+                       --without-jpeg-mmx \
+                       --without-mysql \
+                       --without-pgsql \
+)
+endef
+
+define Build/Compile   
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/motion/install  
+       install -d -m0755 $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,motion))
diff --git a/multimedia/motion/patches/01-ffmpeg.patch b/multimedia/motion/patches/01-ffmpeg.patch
new file mode 100644 (file)
index 0000000..1f4c73e
--- /dev/null
@@ -0,0 +1,38 @@
+diff -ur motion-3.2.5.1-old/motion.c motion-3.2.5.1/motion.c
+--- motion-3.2.5.1-old/motion.c        2006-03-17 10:05:13.490000000 -0800
++++ motion-3.2.5.1/motion.c    2006-03-17 10:03:38.020000000 -0800
+@@ -1246,10 +1246,10 @@
+                * Note: Negative value means SIGALRM snaps are enabled
+                * httpd-control snaps are always enabled.
+                */
+-              
++#ifdef HAVE_FFMPEG            
+               /* time_current_frame is used both for snapshot and timelapse features */
+               time_current_frame = cnt->currenttime;          
+-              
++
+               if ( (cnt->conf.snapshot_interval > 0 && cnt->shots == 0 &&
+                     time_current_frame % cnt->conf.snapshot_interval <= time_last_frame % cnt->conf.snapshot_interval) ||
+                   cnt->snapshot) {
+@@ -1257,7 +1257,7 @@
+                       cnt->snapshot = 0;
+               }
+-
++#endif /* HAVE_FFMPEG */
+       /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
+ #ifdef HAVE_FFMPEG
+@@ -1331,10 +1331,9 @@
+                       event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
+                       
+               
+-#endif /* HAVE_FFMPEG */
+               time_last_frame = time_current_frame;
+-
++#endif /* HAVE_FFMPEG */
+       /***** MOTION LOOP - VIDEO LOOPBACK SECTION *****/
+Only in motion-3.2.5.1-old/: motion.c.orig
diff --git a/multimedia/motion/patches/02-honor_cppflags.patch b/multimedia/motion/patches/02-honor_cppflags.patch
new file mode 100644 (file)
index 0000000..322fb77
--- /dev/null
@@ -0,0 +1,20 @@
+diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
+--- motion-3.2.5.1-old/Makefile.in     2006-03-07 22:52:49.000000000 +0100
++++ motion-3.2.5.1-new/Makefile.in     2006-03-27 22:04:34.000000000 +0200
+@@ -32,6 +32,7 @@
+ ################################################################################
+ CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
+              -Dsysconfdir=\"$(sysconfdir)\"
++CPPFLAGS     = @CPPFLAGS@
+ LDFLAGS      = @LDFLAGS@
+ LIBS         = @LIBS@ 
+ VIDEO_OBJ    = @VIDEO@
+@@ -115,7 +116,7 @@
+ ################################################################################
+ $(DEPEND_FILE): *.h $(SRC)
+       @echo "Generating dependencies, please wait..."
+-      @$(CC) $(CFLAGS) -M $(SRC) > .tmp
++      @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
+       @mv -f .tmp $(DEPEND_FILE)
+       @echo