[buildroot] move LIB_SUFFIX from base-files to rules.mk
authorFlorian Fainelli <florian@openwrt.org>
Fri, 10 Aug 2012 14:15:06 +0000 (14:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 10 Aug 2012 14:15:06 +0000 (14:15 +0000)
Some packages are going to need fixups based on LIB_SUFFIX

SVN-Revision: 33080

package/base-files/Makefile
rules.mk

index bb88d5d32ddfb3dcb89015f60e0686b418c3eec0..441d394288fac2a88b8ee389bca0a638b3ab4f68 100644 (file)
@@ -23,9 +23,6 @@ ifneq ($(DUMP),1)
   ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
     TARGET:=$(TARGET)-$(PROFILE)
   endif
-  ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
-    LIB_SUFFIX:=64
-  endif
 endif
 
 define Package/base-files
index 114b16ce3a2d75d8748aefa21d6323d4037a541b..abb961e7dea5ec49bc751411ce8d2aac5e1a56ea 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -122,6 +122,10 @@ endif
 LIBRPC=-lrpc
 LIBRPC_DEPENDS=+librpc
 
+ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
+  LIB_SUFFIX:=64
+endif
+
 ifndef DUMP
   ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
     -include $(TOOLCHAIN_DIR)/info.mk