[package] do not ignore enabled option in init script, bump release number (#6072)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 23 Nov 2009 00:35:38 +0000 (00:35 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 23 Nov 2009 00:35:38 +0000 (00:35 +0000)
SVN-Revision: 18491

net/miniupnpd/Makefile
net/miniupnpd/files/miniupnpd.init

index 61261c7e720559732849d80da80bfd174e8ca956..430228105023c562ddd82038dc7ca1059bd0c9e2 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_MD5SUM:=b5e70e80dcf45b424b8fe3c966bdc613
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
index 5bcf8bc99eb5ac1823e63600dedb466ff057ccce..4705fc8fcd409eb9a7b451944fc099a641aaafbf 100644 (file)
@@ -3,7 +3,7 @@ START=95
 
 start() {
        config_load "upnpd"
-       local extiface intiface upload download logging secure
+       local extiface intiface upload download logging secure enabled
 
        config_get extiface config external_iface
        config_get intiface config internal_iface
@@ -11,6 +11,7 @@ start() {
        config_get download config download
        config_get_bool logging config log_output 0
        config_get_bool secure config secure_mode 0
+       config_get_bool enabled config enabled 0 
 
        include /lib/network
        scan_interfaces
@@ -37,9 +38,9 @@ start() {
                        append args "-S"
 
                if [ "$logging" = "1" ]; then
-                       eval start-stop-daemon -S -x miniupnpd -- $args -d | logger -t miniupnpd &
+                       [ "$enabled" -gt 0 ] && eval start-stop-daemon -S -x miniupnpd -- $args -d | logger -t miniupnpd &
                else
-                       eval start-stop-daemon -S -x miniupnpd -- $args 2>/dev/null
+                       [ "$enabled" -gt 0 ] && eval start-stop-daemon -S -x miniupnpd -- $args 2>/dev/null
                fi
 
                # start firewall