added shorewall from #2553
authorJohn Crispin <john@openwrt.org>
Thu, 18 Oct 2007 19:36:15 +0000 (19:36 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 18 Oct 2007 19:36:15 +0000 (19:36 +0000)
SVN-Revision: 9353

net/shorewall-common/Makefile [new file with mode: 0644]
net/shorewall-common/files/hostname [new file with mode: 0644]
net/shorewall-common/files/shorewall.init [new file with mode: 0644]
net/shorewall-shell/Makefile [new file with mode: 0644]

diff --git a/net/shorewall-common/Makefile b/net/shorewall-common/Makefile
new file mode 100644 (file)
index 0000000..6c3941a
--- /dev/null
@@ -0,0 +1,52 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7845 2007-07-01 23:09:45Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shorewall-common
+PKG_VERSION:=4.0.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=70e32b1dcd56f0bbd3599ff5d9246217
+
+PKG_SOURCE_URL:=http://www1.shorewall.net/pub/shorewall/4.0/shorewall-$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/shorewall-common
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+shorewall-shell
+  TITLE:=Shorewall
+  URL:=http://www.shorewall.net/
+  SUBMENU:=firewall
+endef
+
+define Package/shorewall-common/description
+       Shorewall Firewall is an iptables-based firewall for Linux.
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       PREFIX=$(PKG_INSTALL_DIR) $(PKG_BUILD_DIR)/install.sh
+endef
+
+define Package/shorewall-common/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/usr/share
+       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_BIN) ./files/shorewall.init $(1)/etc/init.d/shorewall
+       $(INSTALL_BIN) ./files/hostname $(1)/bin
+       $(CP) $(PKG_INSTALL_DIR)/sbin/shorewall $(1)/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/etc/shorewall $(1)/etc
+endef
+
+$(eval $(call BuildPackage,shorewall-common))
diff --git a/net/shorewall-common/files/hostname b/net/shorewall-common/files/hostname
new file mode 100644 (file)
index 0000000..48edcae
--- /dev/null
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+. /etc/functions.sh
+config_load "system"
+local section="cfg1"
+config_get "hostname"  "$section" "hostname"
+
+echo "$hostname"
diff --git a/net/shorewall-common/files/shorewall.init b/net/shorewall-common/files/shorewall.init
new file mode 100644 (file)
index 0000000..691e61c
--- /dev/null
@@ -0,0 +1,31 @@
+#!/bin/sh /etc/rc.common
+
+START=46
+start() {
+        touch /var/log/messages
+        mkdir -p /var/lock/subsys
+        /sbin/shorewall -f start 1>/dev/null &
+}
+
+stop() {
+        /sbin/shorewall stop 1>/dev/null
+}
+
+restart() {
+        if [ -f /var/lib/shorewall/restore ] ; then
+        /sbin/shorewall restore
+        else
+        /sbin/shorewall restart 1>/dev/null
+        fi
+}
+refresh() {
+        /sbin/shorewall refresh
+}
+
+check() {
+        /sbin/shorewall check
+}
+
+reset() {
+        /sbin/shorewall reset
+}
\ No newline at end of file
diff --git a/net/shorewall-shell/Makefile b/net/shorewall-shell/Makefile
new file mode 100644 (file)
index 0000000..356b938
--- /dev/null
@@ -0,0 +1,45 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7845 2007-07-01 23:09:45Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shorewall-shell
+PKG_VERSION:=4.0.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=1b1a4101e206c3c0e9ae2e3190c8aaf3
+
+PKG_SOURCE_URL:=http://www1.shorewall.net/pub/shorewall/4.0/shorewall-$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/shorewall-shell
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+iptables
+  TITLE:=Shorewall Shell
+  URL:=http://www.shorewall.net/
+  SUBMENU:=firewall
+endef
+
+define Package/shorewall-shell/description
+       Shoreline Firewall shell-based compiler.
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       PREFIX=$(PKG_INSTALL_DIR) $(PKG_BUILD_DIR)/install.sh
+endef
+
+define Package/shorewall-shell/install
+       $(INSTALL_DIR) $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall-shell $(1)/usr/share
+endef
+
+$(eval $(call BuildPackage,shorewall-shell))