port usbutils to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Mon, 24 Jul 2006 07:27:51 +0000 (07:27 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 24 Jul 2006 07:27:51 +0000 (07:27 +0000)
SVN-Revision: 4253

utils/usbutils/Makefile [new file with mode: 0644]

diff --git a/utils/usbutils/Makefile b/utils/usbutils/Makefile
new file mode 100644 (file)
index 0000000..28f44fd
--- /dev/null
@@ -0,0 +1,81 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=usbutils
+PKG_VERSION:=0.71
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/linux-usb
+PKG_MD5SUM:=479d7c7098ef44cc95e7978fd71c712c
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/usbutils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libusb
+  TITLE:=USB devices listing utilities
+  DESCRIPTION:=USB devices listing utilities.
+  URL:=http://linux-usb.sourceforge.net/
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/usbutils/install
+       install -d -m0755 $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
+       install -d -m0755 $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/usb.ids $(1)/usr/share/
+endef
+
+$(eval $(call BuildPackage,usbutils))